POV-Ray : Newsgroups : povray.unix : Freebsd : Server Time: 14 Dec 2018 09:36:04 GMT
  Freebsd : (Message 1 to 3 of 3)  
From: tth
Subject: Freebsd :
Date: 28 Apr 2018 08:57:23
Message: <5ae43773$1@news.povray.org>
Hello

I'm trying to compile POV on FreeBSD (11.1-RELEASE-p1).

./prebuild was OK but i got the usual error on boost at
the ./configure step :

checking whether more special flags are required for pthreads... no
checking for PTHREAD_PRIO_INHERIT... yes
checking for boostlib >= 1.38... yes
checking whether the Boost::Thread library is available... yes
checking for exit in -lboost_thread... yes
checking whether the boost thread library is usable... no
configure: error: in `/home/tth/Softwares/povray-3.8.0-alpha.9606898':
configure: error: cannot link with the boost thread library
See `config.log' for more details

The full log : http://la.buvette.org/vrac/povray-config-log.txt

Any help welcome...

tTh


Post a reply to this message

From: clipka
Subject: Re: Freebsd :
Date: 28 Apr 2018 10:56:18
Message: <5ae45352$1@news.povray.org>
Am 28.04.2018 um 10:53 schrieb tth:
> Hello
> 
> I'm trying to compile POV on FreeBSD (11.1-RELEASE-p1).
> 
> ../prebuild was OK but i got the usual error on boost at
> the ./configure step :
> 
> checking whether more special flags are required for pthreads... no
> checking for PTHREAD_PRIO_INHERIT... yes
> checking for boostlib >= 1.38... yes
> checking whether the Boost::Thread library is available... yes
> checking for exit in -lboost_thread... yes
> checking whether the boost thread library is usable... no
> configure: error: in `/home/tth/Softwares/povray-3.8.0-alpha.9606898':
> configure: error: cannot link with the boost thread library
> See `config.log' for more details
> 
> The full log : http://la.buvette.org/vrac/povray-config-log.txt
> 
> Any help welcome...

From what I could gather from the interwebs, the error message

/usr/local/lib/compat/libstdc++.so.6: version CXXABI_1.3.9 required by
/usr/home/tth/Softwares/povray-3.8.0-alpha.9606898/conftest not found

indicates that the compiler/linker chosen to build POV-Ray is building
code for ABI version 1.3.9, which the C++ runtime library (libstdc++)
installed on your machine does not support.

The ABI (Application Binary Interface) is a convention of how a compiler
shall translate certain source code constructs at the machine level
(e.g. how many parameters of a function are to be passed via registers
rather than on the stack, what registers are to be used for this
purpose, whether float parameters are to be passed in x87 or AVX
registers, how C++ overloaded functions names are "mangled" so that each
function name is unique, whether `int` is 32 or 64 bits wide on a 64-bit
machine, etc.), so that at this fundamental level a compiled application
will interact properly with the various dynamically linked libraries
that were compiled earlier (or have been updated since the application
was compiled).

Not sure how to solve this issue (I'm a Windows jockey after all), but
this issue is certainly beyond the scope of an application's source code
or even its build process; so it is /not/ a problem specific to POV-Ray,
and you may need to get help elsewhere. The internerds indicate that you
may need to use a different compiler.


Post a reply to this message

From: clipka
Subject: Re: Freebsd :
Date: 28 Apr 2018 11:15:10
Message: <5ae457be$1@news.povray.org>
Am 28.04.2018 um 12:56 schrieb clipka:

> /usr/local/lib/compat/libstdc++.so.6: version CXXABI_1.3.9 required by
> /usr/home/tth/Softwares/povray-3.8.0-alpha.9606898/conftest not found
> 
> indicates that the compiler/linker chosen to build POV-Ray is building
> code for ABI version 1.3.9, which the C++ runtime library (libstdc++)
> installed on your machine does not support.

Thinking about this a bit more, I'm coming to doubt that's exactly
what's happening; otherwise the configure script should complain much
earlier, at the very moment it tests whether the C++ compiler works at all.

So with that in mind, it may actually be the boost shared libraries
(more specifically, `libbost_thread`, `libboost_system`, or both) which
require ABI 1.3.9 (meaning they were compiled for that ABI, so your
FreeBSD installation would be inconsistent and in a sense broken). So
maybe you need to look at those rather than the compiler.


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.