POV-Ray : Newsgroups : povray.unix : master branch has problem to compile on Ubuntu 15.04 since 1b5aab6 (27 June 2015) Server Time: 14 Dec 2018 09:59:03 GMT
  master branch has problem to compile on Ubuntu 15.04 since 1b5aab6 (27 June 2015) (Message 1 to 3 of 3)  
From: Le Forgeron
Subject: master branch has problem to compile on Ubuntu 15.04 since 1b5aab6 (27 June 2015)
Date: 3 Aug 2015 18:54:24
Message: <55bfb8e0$1@news.povray.org>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

The master branch of povray (from github), since commit 1b5aab6 (27
June 2015) has a problem that stop compiling the code:

boost::scoped_ptr needs #include <boost/scoped_ptr.hpp>, but so far
parser.cpp (source/parser/parser.cpp) is lacking that include.

Maybe it was implicitly included in version of boost before 1.55, but
on 1.55 (the only one available with Ubuntu Vivid 15.04), it is
missing and compilers do not like it.



-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iJwEAQEIAAYFAlW/uOAACgkQhKAm8mTpkW1iEQQAhdkI8uSg7ZjrWLsQwyvX2g/C
cNhaXxYXkcwWKD3O+8XB9xauisKGbZbjkROnsdanAPeZbZ1ns0IlmKx5yiWwMl4h
Fg8J2tf9CmWbqiOa9QJcn/Yek7AMgiZbDuHPI1R/fKOUgb3dMrEWRhzX6yDr/bpU
W48KmB8iH/hj8WOrG1E=
=67Cw
-----END PGP SIGNATURE-----


Post a reply to this message

From: eticre
Subject: Re: master branch has problem to compile on Ubuntu 15.04 since 1b5aab6 (27 =
Date: 16 Sep 2015 19:00:00
Message: <web.55f9bc091b8e43f66a4da3b40@news.povray.org>
Le_Forgeron <jgr### [at] freefr> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
>
> The master branch of povray (from github), since commit 1b5aab6 (27
> June 2015) has a problem that stop compiling the code:
>
> boost::scoped_ptr needs #include <boost/scoped_ptr.hpp>, but so far
> parser.cpp (source/parser/parser.cpp) is lacking that include.
>
> Maybe it was implicitly included in version of boost before 1.55, but
> on 1.55 (the only one available with Ubuntu Vivid 15.04), it is
> missing and compilers do not like it.
>
>
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v2
>
> iJwEAQEIAAYFAlW/uOAACgkQhKAm8mTpkW1iEQQAhdkI8uSg7ZjrWLsQwyvX2g/C
> cNhaXxYXkcwWKD3O+8XB9xauisKGbZbjkROnsdanAPeZbZ1ns0IlmKx5yiWwMl4h
> Fg8J2tf9CmWbqiOa9QJcn/Yek7AMgiZbDuHPI1R/fKOUgb3dMrEWRhzX6yDr/bpU
> W48KmB8iH/hj8WOrG1E=
> =67Cw
> -----END PGP SIGNATURE-----

same problem in archlinux
add "#include <boost/scoped_ptr.hpp>" in parser.cpp to avoid error


Post a reply to this message

From: clipka
Subject: Re: master branch has problem to compile on Ubuntu 15.04 since 1b5aab6 (27 =
Date: 18 Sep 2015 17:15:14
Message: <55fc46a2$1@news.povray.org>
Am 16.09.2015 um 20:59 schrieb eticre:
> Le_Forgeron <jgr### [at] freefr> wrote:
> The master branch of povray (from github), since commit 1b5aab6 (27
> June 2015) has a problem that stop compiling the code:
> 
> boost::scoped_ptr needs #include <boost/scoped_ptr.hpp>, but so far
> parser.cpp (source/parser/parser.cpp) is lacking that include.
> 
> Maybe it was implicitly included in version of boost before 1.55, but
> on 1.55 (the only one available with Ubuntu Vivid 15.04), it is
> missing and compilers do not like it.
> 
> 
> 
> 
> same problem in archlinux
> add "#include <boost/scoped_ptr.hpp>" in parser.cpp to avoid error

Should be fixed now.


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.