POV-Ray : Newsgroups : povray.unix : Problem while trying to install libjpeg8-dev Server Time: 14 Dec 2018 11:07:28 GMT
  Problem while trying to install libjpeg8-dev (Message 1 to 5 of 5)  
From: Jörg 'Yadgar' Bleimann
Subject: Problem while trying to install libjpeg8-dev
Date: 25 Jun 2015 23:23:20
Message: <558c8d68$1@news.povray.org>
Hi(gh)!

Now I embarked on the long, long journey to GeoPOV, my binary mesh patch 
project aimed at creating slices of planetary surfaces from image files 
or even ASCII elevation data without generating gigabytes of ASCII code 
overhead (see also thread on povray.general)... first station will be 
compiling the current stable POV-Ray 3.7 distribution from GitHub under 
Linux.

unix/README.md recommends to have (among others) libjpeg8-dev 
pre-installed before starting the prebuild.sh script. When I tried this:

apt-get install libjpeg8-dev

I got the following error message (translated from German):

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
  libjpeg8-dev : Hängt ab von: libjpeg8 (= 8b-1) aber 8d-1+deb7u1 soll 
installiert werden

The following packages have unsolved dependences_
   libjpeg8-dev : Depends on: libjpeg8 (= 8b-1) but 8d-1+deb7u1 shall be 
installed

How can I fix this?

See you in Khyberspace!

Yadgar


Post a reply to this message

From: clipka
Subject: Re: Problem while trying to install libjpeg8-dev
Date: 26 Jun 2015 01:39:56
Message: <558cad6c$1@news.povray.org>
Am 26.06.2015 um 01:23 schrieb Jörg 'Yadgar' Bleimann:
> Hi(gh)!
>
> Now I embarked on the long, long journey to GeoPOV, my binary mesh patch
> project aimed at creating slices of planetary surfaces from image files
> or even ASCII elevation data without generating gigabytes of ASCII code
> overhead (see also thread on povray.general)... first station will be
> compiling the current stable POV-Ray 3.7 distribution from GitHub under
> Linux.
>
> unix/README.md recommends to have (among others) libjpeg8-dev
> pre-installed before starting the prebuild.sh script. When I tried this:
>
> apt-get install libjpeg8-dev
>
> I got the following error message (translated from German):
>
> Die folgenden Pakete haben unerfüllte Abhängigkeiten:
>   libjpeg8-dev : Hängt ab von: libjpeg8 (= 8b-1) aber 8d-1+deb7u1 soll
> installiert werden
>
> The following packages have unsolved dependences_
>    libjpeg8-dev : Depends on: libjpeg8 (= 8b-1) but 8d-1+deb7u1 shall be
> installed

The corresponding English message would actually be:

The following packages have unmet dependencies:
  libjpeg8-dev : Depends: libjpeg8 (= 8b-1) but 8d-1+deb7u1 is to be 
installed

As far as I understand, this means that libjpeg8 version 8b-1 is 
currently installed on your system, but the most recent libjpeg8-dev 
version is 8d-1+deb7u1; apt-get is complaining that they don't fit together.

You need to either specifically install the libjpeg8-dev matching your 
installed libjpeg8, which (as far as I understand) the following command 
should do:

   apt-get install libjpeg8-dev=8b-1

or you need to upgrade libjpeg8 to the most recent version:

   apt-get upgrade libjpeg8
   apt-get install libjpeg8-dev


Post a reply to this message

From: Jörg 'Yadgar' Bleimann
Subject: Re: Problem while trying to install libjpeg8-dev
Date: 26 Jun 2015 02:30:29
Message: <558cb945$1@news.povray.org>
On 26.06.2015 03:39, clipka wrote:

> You need to either specifically install the libjpeg8-dev matching your
> installed libjpeg8, which (as far as I understand) the following command
> should do:
>
>    apt-get install libjpeg8-dev=8b-1
>
> or you need to upgrade libjpeg8 to the most recent version:
>
>    apt-get upgrade libjpeg8
>    apt-get install libjpeg8-dev

Neither worked - when tryintg to install libjpeg-dev=8b-1 or 
libjpeg8-dev, I get the same error message again, when I try to upgrad 
libjpeg8, apt-get says it is already the latest version... instead I got 
a lengthy list of now disused packages which may be removed by using 
apt-get autoremove - which I did afterwards. But even after this, your 
suggestions did not work, messages were like before.

See you in Khyberspace!

Yadgar


Post a reply to this message

From: eticre
Subject: Re: Problem while trying to install libjpeg8-dev
Date: 27 Jun 2015 19:10:12
Message: <web.558ef3e26c9fc1a8854728760@news.povray.org>
Hi

seems you try install libjpeg8-dev from wheezy repo but have squeeze installed

https://packages.debian.org/search?keywords=libjpeg8


Post a reply to this message

From: Jörg 'Yadgar' Bleimann
Subject: Re: Problem while trying to install libjpeg8-dev
Date: 29 Jun 2015 23:19:17
Message: <5591d275$1@news.povray.org>
Hi(gh)!

On 27.06.2015 21:05, eticre wrote:
> Hi
>
> seems you try install libjpeg8-dev from wheezy repo but have squeeze installed
>
> https://packages.debian.org/search?keywords=libjpeg8

I tried replacing "squeeze" by "wheezy" in my first repository list 
entry, and, yes, it worked! Thank you very much!

See you in Khyberspace!

Yadgar


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.