POV-Ray : Newsgroups : povray.unix : Trying to build on OpenSuse 13.1 Server Time: 16 Jun 2019 08:02:04 GMT
  Trying to build on OpenSuse 13.1 (Message 1 to 10 of 12)  
Goto Latest 10 Messages Next 2 Messages >>>
From: Warp
Subject: Trying to build on OpenSuse 13.1
Date: 26 Sep 2014 12:29:38
Message: <54255c32@news.povray.org>
I recently upgraded top OpenSuse 13.1, and my old build of povray isn't
working anymore (something about a missing .so), so I decided to build
the latest version.

I didn't have autoconf nor automake installed, and prebuild.sh gave
proper messages about them, so I installed them. However, now I'm getting
a lot of messages like:

configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body

/usr/share/automake-1.13/am/library.am: warning: 'libpovray.a': linking libraries
using a non-POSIX
/usr/share/automake-1.13/am/library.am: archiver requires 'AM_PROG_AR' in
'configure.ac'
source/Makefile.am:32:   while processing library 'libpovray.a'

configure.ac:295: warning: The macro `AC_LANG_SAVE' is obsolete.
configure.ac:295: warning: The macro `AC_LANG_C' is obsolete.
configure.ac:295: warning: The macro `AC_TRY_LINK' is obsolete.
configure.ac:295: warning: The macro `AC_LANG_RESTORE' is obsolete.

In the end, no 'configure' script appeared. I don't really know what
causes this.

-- 
                                                          - Warp


Post a reply to this message

From: Warp
Subject: Re: Trying to build on OpenSuse 13.1
Date: 26 Sep 2014 12:30:56
Message: <54255c80@news.povray.org>
Warp <war### [at] tagpovrayorg> wrote:
> In the end, no 'configure' script appeared. I don't really know what
> causes this.

Correction: It actually did appear, just not in the same directory
as prebuild.sh...

-- 
                                                          - Warp


Post a reply to this message

From: Warp
Subject: Re: Trying to build on OpenSuse 13.1
Date: 26 Sep 2014 12:37:14
Message: <54255dfa@news.povray.org>
configure fails with this:

configure:7284: checking for boostlib >= 1.37
configure:7338: g++ -c  -pthread  -I/usr/include conftest.cpp >&5
configure:7338: $? = 0
configure:7340: result: yes
configure:7506: checking whether the Boost::Thread library is available
configure:7538: g++ -c -pthread  -pthread  -I/usr/include conftest.cpp >&5
configure:7538: $? = 0
configure:7553: result: yes
configure:7749: checking whether the boost thread library is usable
configure:7769: g++ -o conftest  -pthread  -pthread -I/usr/include  -L/usr/lib c
onftest.cpp   -pthread  >&5
/tmp/ccQTte5D.o: In function `__static_initialization_and_destruction_0(int, int
)':
conftest.cpp:(.text+0x4f): undefined reference to `boost::system::generic_category()'
conftest.cpp:(.text+0x5b): undefined reference to `boost::system::generic_category()'
conftest.cpp:(.text+0x67): undefined reference to `boost::system::system_category()'
collect2: error: ld returned 1 exit status


-- 
                                                          - Warp


Post a reply to this message

From: Le Forgeron
Subject: Re: Trying to build on OpenSuse 13.1
Date: 26 Sep 2014 14:12:30
Message: <5425744e@news.povray.org>
Le 26/09/2014 14:37, Warp a écrit :
> configure fails with this:
> 
> configure:7284: checking for boostlib >= 1.37
> configure:7338: g++ -c  -pthread  -I/usr/include conftest.cpp >&5
> configure:7338: $? = 0
> configure:7340: result: yes
> configure:7506: checking whether the Boost::Thread library is available
> configure:7538: g++ -c -pthread  -pthread  -I/usr/include conftest.cpp >&5
> configure:7538: $? = 0
> configure:7553: result: yes
> configure:7749: checking whether the boost thread library is usable
> configure:7769: g++ -o conftest  -pthread  -pthread -I/usr/include  -L/usr/lib c
> onftest.cpp   -pthread  >&5
> /tmp/ccQTte5D.o: In function `__static_initialization_and_destruction_0(int, int
> )':
> conftest.cpp:(.text+0x4f): undefined reference to
`boost::system::generic_category()'
> conftest.cpp:(.text+0x5b): undefined reference to
`boost::system::generic_category()'
> conftest.cpp:(.text+0x67): undefined reference to `boost::system::system_category()'
> collect2: error: ld returned 1 exit status
> 
> 

Blind reflex with boost: add   LIBS="-lboost_system -lboost_thread" to
the configure line.

And hope that everything-dev of boost is installed.

-- 
Just because nobody complains does not mean all parachutes are perfect.


Post a reply to this message

From: Warp
Subject: Re: Trying to build on OpenSuse 13.1
Date: 26 Sep 2014 14:42:54
Message: <54257b6e@news.povray.org>
Le_Forgeron <lef### [at] freefr> wrote:
> Blind reflex with boost: add   LIBS="-lboost_system -lboost_thread" to
> the configure line.

Raises the queston why the configure script doesn't do this itself...

-- 
                                                          - Warp


Post a reply to this message

From: Le Forgeron
Subject: Re: Trying to build on OpenSuse 13.1
Date: 26 Sep 2014 15:55:25
Message: <54258c6d$1@news.povray.org>
On 26/09/2014 16:42, Warp wrote:
> Le_Forgeron <lef### [at] freefr> wrote:
>> Blind reflex with boost: add   LIBS="-lboost_system -lboost_thread" to
>> the configure line.
> 
> Raises the queston why the configure script doesn't do this itself...
> 
Well... it worked with old revision of boost... then they broke it (the
linkage is no more done by boost)... it broke around 1.47 or 1.48, IIRC.

Boost have their own motivation (including: to allow someone, despite
the default being to use native thread, to use their own thread... or
its own system for the thread...).

For the configure script of povray: well, lack of manpower, lack of
competence, and it appears past the release date of povray
(when it was tested at that time, boost was still fine).

Povray is now in github, so if you feel to make a patch, well, go for
it: make a fork, make the correction and create the pull request on the
official branch.

-- 
IQ of crossposters with FU: 100 / (number of groups)
IQ of crossposters without FU: 100 / (1 + number of groups)
IQ of multiposters: 100 / ( (number of groups) * (number of groups))


Post a reply to this message

From: clipka
Subject: Re: Trying to build on OpenSuse 13.1
Date: 26 Sep 2014 16:52:01
Message: <542599b1$1@news.povray.org>
Am 26.09.2014 14:30, schrieb Warp:
> Warp <war### [at] tagpovrayorg> wrote:
>> In the end, no 'configure' script appeared. I don't really know what
>> causes this.
>
> Correction: It actually did appear, just not in the same directory
> as prebuild.sh...

So everything's fine until that point; the warnings are... well, just 
warnings, that from a first glance look familiar.


Post a reply to this message

From: clipka
Subject: Re: Trying to build on OpenSuse 13.1
Date: 26 Sep 2014 16:57:39
Message: <54259b03@news.povray.org>
Am 26.09.2014 17:55, schrieb Le_Forgeron:
> On 26/09/2014 16:42, Warp wrote:
>> Le_Forgeron <lef### [at] freefr> wrote:
>>> Blind reflex with boost: add   LIBS="-lboost_system -lboost_thread" to
>>> the configure line.
>>
>> Raises the queston why the configure script doesn't do this itself...
>>
> Well... it worked with old revision of boost... then they broke it (the
> linkage is no more done by boost)... it broke around 1.47 or 1.48, IIRC.

The nasty thing is that we fixed it (or so I vaguely recall), but looks 
like it's come back.


> For the configure script of povray: well, lack of manpower, lack of
> competence, and it appears past the release date of povray
> (when it was tested at that time, boost was still fine).

Hm... I think "competence" might be a "false friend" in this context. Dunno.


Post a reply to this message

From: Le Forgeron
Subject: Re: Trying to build on OpenSuse 13.1
Date: 26 Sep 2014 18:53:55
Message: <5425b643$1@news.povray.org>
On 26/09/2014 18:57, clipka wrote:
> Am 26.09.2014 17:55, schrieb Le_Forgeron:
>> On 26/09/2014 16:42, Warp wrote:
>>> Le_Forgeron <lef### [at] freefr> wrote:
>>>> Blind reflex with boost: add   LIBS="-lboost_system -lboost_thread" to
>>>> the configure line.
>>>
>>> Raises the queston why the configure script doesn't do this itself...
>>>
>> Well... it worked with old revision of boost... then they broke it (the
>> linkage is no more done by boost)... it broke around 1.47 or 1.48, IIRC.
> 
> The nasty thing is that we fixed it (or so I vaguely recall), but looks
> like it's come back.
> 
> 
>> For the configure script of povray: well, lack of manpower, lack of
>> competence, and it appears past the release date of povray
>> (when it was tested at that time, boost was still fine).
> 
> Hm... I think "competence" might be a "false friend" in this context.
> Dunno.
> 
You are probably right, it was Friday end-of-day.

You should have repeated the step to help :-)

-- 
IQ of crossposters with FU: 100 / (number of groups)
IQ of crossposters without FU: 100 / (1 + number of groups)
IQ of multiposters: 100 / ( (number of groups) * (number of groups))


Post a reply to this message

From: Ger
Subject: Re: Trying to build on OpenSuse 13.1
Date: 26 Sep 2014 20:01:17
Message: <5425c60d$1@news.povray.org>
Warp wrote:

> I recently upgraded top OpenSuse 13.1, and my old build of povray isn't
> working anymore (something about a missing .so), so I decided to build
> the latest version.
> 
> I didn't have autoconf nor automake installed, and prebuild.sh gave
> proper messages about them, so I installed them. However, now I'm getting
> a lot of messages like:
> 
> configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
> detected in body
> 
> /usr/share/automake-1.13/am/library.am: warning: 'libpovray.a': linking
> libraries using a non-POSIX /usr/share/automake-1.13/am/library.am:
> archiver requires 'AM_PROG_AR' in 'configure.ac'
> source/Makefile.am:32:   while processing library 'libpovray.a'
> 
> configure.ac:295: warning: The macro `AC_LANG_SAVE' is obsolete.
> configure.ac:295: warning: The macro `AC_LANG_C' is obsolete.
> configure.ac:295: warning: The macro `AC_TRY_LINK' is obsolete.
> configure.ac:295: warning: The macro `AC_LANG_RESTORE' is obsolete.
> 
> In the end, no 'configure' script appeared. I don't really know what
> causes this.
> 
# filename install_povray.sh

# install script for Povray 3.7 master
# this script must be run by root

# First we need to install a bunch of libs that make
# life a whole lot easier when using/compiling Povray

zypper in -l -y automake
zypper in -l -y autoconf
zypper in -l -y boost-devel
zypper in -l -y make
zypper in -l -y gcc
zypper in -l -y gcc-c++
zypper in -l -y libjpeg8-devel
zypper in -l -y openexr-devel
zypper in -l -y openexr
zypper in -l -y libpng12-devel
zypper in -l -y libtiff-devel
zypper in -l -y libSDL-devel
zypper in -l -y libSDL2-devel
zypper in -l -y libXpm-devel
zypper in -l -y libXpm-tools
zypper in -l -y libICE-devel
zypper in -l -y libSM-devel

#prepair for unix (linux) compilation
cd /home/ger/Downloads/povray-master/unix/

# and run the prebuild script
./prebuild.sh

# run configure with the appropriate options
cd /home/ger/Downloads/povray-master
./configure COMPILED_BY="Your Name <email.com>" --with-boost-thread=boost_thread-mt
LIBS="-lboost_system -lboost_thread"


# and now for the heavy lifting part . . .
# Make and install povray

make clean  
make install



# all done


HTH
-- 

Ger


Post a reply to this message

Goto Latest 10 Messages Next 2 Messages >>>

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.