POV-Ray : Newsgroups : povray.unix : Cannot compile 3.7 on XUbuntu 13.10 x64 Server Time: 21 Jul 2018 23:25:10 GMT
  Cannot compile 3.7 on XUbuntu 13.10 x64 (Message 1 to 5 of 5)  
From: Timothy Groves
Subject: Cannot compile 3.7 on XUbuntu 13.10 x64
Date: 28 Dec 2013 18:15:02
Message: <52bf1526$1@news.povray.org>
I downloaded 3.7RC7, and started with a ./configure, and got this error 
message:

checking for boostlib >= 1.37... yes
checking whether the Boost::Thread library is available... yes
checking whether the boost thread library is usable... no
configure: error: in `/home/rakshasa/Downloads/tmp/povray-3.7.0.RC7':
configure: error: cannot link with the boost thread library
See `config.log' for more details

config.log had the following to say:

configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "POV-Ray"
| #define PACKAGE_TARNAME "povray"
| #define PACKAGE_VERSION "3.7.0.RC7"
| #define PACKAGE_STRING "POV-Ray 3.7.0.RC7"
| #define PACKAGE_BUGREPORT "unix-bugreports-2011@povray.org"
| #define PACKAGE_URL ""
| #define VERSION_BASE "3.7"
| #define DISTRIBUTION_MESSAGE_2 " Timothy Groves 
<tim### [at] gmailcom>"
| #define PACKAGE "povray"
| #define VERSION "3.7.0.RC7"
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define HAVE_STDLIB_H 1
| #define BUILD_ARCH "x86_64-unknown-linux-gnu"
| #define COMPILER_VENDOR "gnu"
| #define COMPILER_VERSION "g++ 4.8"
| #define COMPILER_VER " (g++ 4.8 @ x86_64-unknown-linux-gnu)"
| #define HAVE_PTHREAD 1
| #define HAVE_BOOST /**/
| #define HAVE_BOOST_THREAD /**/
| /* end confdefs.h.  */
|
| #include <boost/thread/thread.hpp>
|
| int
| main ()
| {
| boost::defer_lock_t(); return 0;
|   ;
|   return 0;
| }

I am running XUbuntu 13.10 x64 on a Core i7-2600.  I tried the 
--with-boost-thread=boost_thread-mt flag suggested on the download page, 
but it didn't help.

Any suggestions?


Post a reply to this message

From: Le Forgeron
Subject: Re: Cannot compile 3.7 on XUbuntu 13.10 x64
Date: 28 Dec 2013 18:28:14
Message: <52bf183e$1@news.povray.org>
Le 28/12/2013 19:15, Timothy Groves nous fit lire :
> I downloaded 3.7RC7, and started with a ./configure, and got this error
> message:
> 
> checking for boostlib >= 1.37... yes
> checking whether the Boost::Thread library is available... yes
> checking whether the boost thread library is usable... no
> configure: error: in `/home/rakshasa/Downloads/tmp/povray-3.7.0.RC7':
> configure: error: cannot link with the boost thread library
> See `config.log' for more details
> 

> I am running XUbuntu 13.10 x64 on a Core i7-2600.  I tried the
> --with-boost-thread=boost_thread-mt flag suggested on the download page,
> but it didn't help.
> 
> Any suggestions?

known problem.

add LIBS="-lboost_system -lboost_thread" to your ./configure (and drop
--with...)

More alternatives at

http://wiki.povray.org/content/User:Le_Forgeron/vault/Compilation


Post a reply to this message

From: clipka
Subject: Re: Cannot compile 3.7 on XUbuntu 13.10 x64
Date: 29 Dec 2013 01:50:26
Message: <52bf7fe2$1@news.povray.org>
Am 28.12.2013 19:15, schrieb Timothy Groves:
> I downloaded 3.7RC7, and started with a ./configure, and got this error
> message:

Why on earth use the 3.7RC7 when you can have the release proper (3.7.0)?


Post a reply to this message

From: jmelson
Subject: Re: Cannot compile 3.7 on XUbuntu 13.10 x64
Date: 22 Jan 2014 19:00:00
Message: <web.52e01443ac7e0665892744560@news.povray.org>
Le_Forgeron <jgr### [at] freefr> wrote:
> Le 28/12/2013 19:15, Timothy Groves nous fit lire :
> > I downloaded 3.7RC7, and started with a ./configure, and got this error
> > message:
> >
> > checking for boostlib >= 1.37... yes
> > checking whether the Boost::Thread library is available... yes
> > checking whether the boost thread library is usable... no
> > configure: error: in `/home/rakshasa/Downloads/tmp/povray-3.7.0.RC7':
> > configure: error: cannot link with the boost thread library
> > See `config.log' for more details
> >
>
> > I am running XUbuntu 13.10 x64 on a Core i7-2600.  I tried the
> > --with-boost-thread=boost_thread-mt flag suggested on the download page,
> > but it didn't help.
> >
> > Any suggestions?
>
> known problem.
>
> add LIBS="-lboost_system -lboost_thread" to your ./configure (and drop
> --with...)
>
> More alternatives at
>
> http://wiki.povray.org/content/User:Le_Forgeron/vault/Compilation

I have the same error.  How do you put this LIBS="~~~" to the
command ./configure command line, or does it need to be in the
configure files?
I tried :
  ./configure LIBS="-lboost_system -lboost_thread" COMPILED_BY="Jon Elson"

But this gave me an error


checking for gcc... gcc
checking whether the C compiler works... no
configure: error: in `/home/elson/software/povray-3.7-stable':
configure: error: C compiler cannot create executables

config.log shows these lines :

gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
configure:4667: $? = 0
configure:4656: gcc -V >&5
gcc: error: unrecognized option '-V'
gcc: fatal error: no input files
compilation terminated.
configure:4667: $? = 4
configure:4656: gcc -qversion >&5
gcc: error: unrecognized option '-qversion'
gcc: fatal error: no input files
compilation terminated.
configure:4667: $? = 4
configure:4687: checking whether the C compiler works
configure:4709: gcc    conftest.c -lboost_system -lboost_thread >&5
/usr/bin/ld: cannot find -lboost_system
/usr/bin/ld: cannot find -lboost_thread


Obviously, the way I added this text to the command line totally
fouled up the gcc command.

Can anybody tell me how to specify this correctly?

Thanks,

Jon


Post a reply to this message

From: Ger
Subject: Re: Cannot compile 3.7 on XUbuntu 13.10 x64
Date: 22 Jan 2014 19:30:13
Message: <52e01c45$1@news.povray.org>
jmelson wrote:

> Can anybody tell me how to specify this correctly?
> 
> Thanks,
> 
> Jon

This is a script that I use to install pov on Opensuse
You may need to adapt it to your system.


#---------------------------
# filename install_povray.sh

# install script for Povray 3.7 master
# this script must very obviously be run by root

# First we need to install a bunch of libs that make
# life a whole lot easier when using/compiling Povray


zypper in -l -y boost-devel
zypper in -l -y make
zypper in -l -y gcc
zypper in -l -y gcc-c++
zypper in -l -y libjpeg8-devel
zypper in -l -y openexr-devel
zypper in -l -y openexr
zypper in -l -y libpng12-devel
zypper in -l -y libtiff-devel
zypper in -l -y libSDL-devel
zypper in -l -y libSDL2-devel
zypper in -l -y libXpm-devel
zypper in -l -y libXpm-tools
zypper in -l -y libICE-devel
zypper in -l -y libSM-devel

#prepair for unix (linux) compilation
cd /home/ger/Downloads/povray-master/unix/

# and run the prebuild script
./prebuild.sh

# run configure with the appropriate options
cd /home/ger/Downloads/povray-master
./configure COMPILED_BY="Pietje Puk <p.p### [at] gmailcom>"
--with-boost-thread=boost_thread-mt LIBS="-lboost_system -lboost_thread"


# and now for the heavy lifting part . . .
# Make and install povray

make clean  
make install



# all done
#---------------------------



-- 

Ger


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.