POV-Ray : Newsgroups : povray.unix : Invalid display, MIT-MAGIC-COOKIE-1 : Re: Invalid display, MIT-MAGIC-COOKIE-1 Server Time: 16 Jun 2019 06:33:26 GMT
  Re: Invalid display, MIT-MAGIC-COOKIE-1  
From: jr
Date: 22 Mar 2019 16:15:00
hi,

Cousin Ricky <ric### [at] yahoocom> wrote:
> Since I upgraded my GNU/Linux system to openSUSE Leap 15.0, I get the
> message "Invalid MIT-MAGIC-COOKIE-1 keyInvalid MIT-MAGIC-COOKIE-1
> keyInvalid MIT-MAGIC-COOKIE-1 key" with every POV 3.7 or 3.8 render.
> This is annoying, but at least the scenes render. But whenever I test a
> scene file with POV 3.5 or 3.6, the render halts with the message:
>
> ------------------- [BEGIN MESSAGE] --------------------
> Displaying...Xlib: connection to ":0.0" refused by server
> Xlib: Invalid MIT-MAGIC-COOKIE-1 key
> Slab Building Error:
> The display ':0' is not a valid display,
> -------------------- [END MESSAGE] ---------------------
>
> The only way I can get any 3.5 or 3.6 renders is to suppress the display
> with -D; but this is impractical when I'm testing a single scene across
> multiple versions.
>
> I've tried to learn about the MIT-MAGIC-COOKIE-1 thing, and have ended
> up entirely flummoxed.  I have tried various simple solutions I've found
> across the Web, and none of them work.  One I haven't tried requires my
> local hostname or IP address.  I don't know what the former means, and
> the latter is unreasonable with dynamically assigned IP addresses.
>
> Has anyone else had this problem, and what can I do to fix it?
>
> OS: openSUSE Leap 15.0 (GNU/Linux)
> Hardware: Dell Inspiron 17R 5720

Slackware systems have a 'mcookie(1)' program installed for the purpose (never
needed to use it though).  available from
ftp.kernel.org/pub/linux/utils/util-linux/.


regards, jr.


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.