POV-Ray : Newsgroups : povray.unix : Packaging povray 3.7 stable for Arch Linux : Re: Packaging povray 3.7 stable for Arch Linux Server Time: 26 Jul 2017 14:34:53 GMT
  Re: Packaging povray 3.7 stable for Arch Linux  
From: Le Forgeron
Date: 12 Nov 2013 23:22:39
Le 12/11/2013 23:04, xyproto nous fit lire :
> 
> Hi,
> 
> 
> Thank you for the replies!
> 
> Good point about povray not specifically targeting Linux.
> 
> 
> Adding LIBS="-lboost_system -lboost_thread" was the right incantation for
> getting one step further in the configuration process.
> 
> 
> I'm using the exact steps as described above, but now using this configure line
> instead:
> 
>  ./configure LIBS="-lboost_system -lboost_thread" COMPILED_BY='Arch Linux'
> --prefix=/usr --sysconfdir=/etc --with-boost-thread=boost_thread
> 
> 
> However, the configuration script now stops at this point in the process:
> 
> 
> Makefiles
> ---------
> checking that generated files are newer than configure... done
> configure: creating ./config.status
> config.status: error: cannot find input file: `Makefile.in'
> 
> 


Failing to reproduce on my Ubuntu 13.10: I reach

===============================================================================
POV-Ray 3.7.0 has been configured.

Built-in features:
  I/O restrictions:          enabled
  X Window display:          enabled (using SDL)
  Supported image formats:   gif tga iff ppm pgm hdr png jpeg tiff openexr
  Unsupported image formats: -

Compilation settings:
  Build architecture:  x86_64-unknown-linux-gnu
  Built/Optimized for: x86_64-unknown-linux-gnu (using -march=native)
  Compiler vendor:     gnu
  Compiler version:    g++ 4.8
  Compiler flags:      -pipe -Wno-multichar -Wno-write-strings
-fno-enforce-eh-specs -s -O3 -ffast-math -march=native -pthread

Type 'make check' to build the program and run a test render.
Type 'make install' to install POV-Ray on your system.

The POV-Ray components will be installed in the following directories:
  Program (executable):       /usr/bin
  System configuration files: /etc/povray/3.7
  User configuration files:   /home/jerome/.povray/3.7
  Standard include files:     /usr/share/povray-3.7/include
  Standard INI files:         /usr/share/povray-3.7/ini
  Standard demo scene files:  /usr/share/povray-3.7/scenes
  Documentation (text, HTML): /usr/share/doc/povray-3.7
  Unix man page:              /usr/share/man





> Further assistance is appreciated.
> 

Makefile.in are generated by prebuild.sh, so maybe you do not have the
needed packages installed ?

Is automake available and working ? (there is a check at the beginning
of script for the version, 1.9+ is required, I have 1.13.3)



My steps were:

> * wget https://github.com/POV-Ray/povray/archive/3.7-stable.zip
> * md5sum 3.7-stable.zip
>   773192125d7c8326c6b730a3aba44318
> * unzip 3.7-stable.zip
> * cd povray-3.7-stable/unix
> * ./prebuild.sh
> * cd ..
> * ./configure COMPILED_BY="Jérôme Grimbert" LIBS="-lboost_system -lboost_thread"
--prefix=/usr --sysconfdir=/etc --with-boost-thread=boost_thread

Notice that with LIBS, the --with-boost-thread might be not needed.



> 
> - Alexander
> 
> 

Hereafter the end of output of prebuild.sh (note: truncated ):

Create ../doc/html
Create ./Makefile.am
Create ../kde_install.sh
Create ../povray.ini.in
Create ../Makefile.am
Create ../bootstrap
Create ../source/Makefile.am
Create ../vfe/Makefile.am
Run ../bootstrap
+ rm -f config.log config.status
+ aclocal -I .
configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2590: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2606: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:639: AS_IF is expanded from...
../../lib/autoconf/general.m4:2031: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2052: AC_CACHE_CHECK is expanded from...
unix/config/ax_boost_thread.m4:32: AX_BOOST_THREAD is expanded from...
configure.ac:302: the top level
+ autoheader --warnings=all
configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2590: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2606: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:639: AS_IF is expanded from...
../../lib/autoconf/general.m4:2031: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2052: AC_CACHE_CHECK is expanded from...
unix/config/ax_boost_thread.m4:32: AX_BOOST_THREAD is expanded from...
configure.ac:302: the top level
+ automake --warnings=all
configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2590: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2606: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:639: AS_IF is expanded from...
../../lib/autoconf/general.m4:2031: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2052: AC_CACHE_CHECK is expanded from...
unix/config/ax_boost_thread.m4:32: AX_BOOST_THREAD is expanded from...
configure.ac:302: the top level
/usr/share/automake-1.13/am/library.am: warning: 'libpovray.a': linking
libraries using a non-POSIX
/usr/share/automake-1.13/am/library.am: archiver requires 'AM_PROG_AR'
in 'configure.ac'
source/Makefile.am:32:   while processing library 'libpovray.a'
/usr/share/automake-1.13/am/library.am: warning: 'libvfe.a': linking
libraries using a non-POSIX
/usr/share/automake-1.13/am/library.am: archiver requires 'AM_PROG_AR'
in 'configure.ac'
vfe/Makefile.am:32:   while processing library 'libvfe.a'
+ autoconf --warnings=all
configure.ac:295: warning: The macro `AC_LANG_SAVE' is obsolete.
configure.ac:295: You should run autoupdate.
../../lib/autoconf/lang.m4:125: AC_LANG_SAVE is expanded from...
unix/config/acx_pthread.m4:78: ACX_PTHREAD is expanded from...
configure.ac:295: the top level
configure.ac:295: warning: The macro `AC_LANG_C' is obsolete.
configure.ac:295: You should run autoupdate.
../../lib/autoconf/c.m4:72: AC_LANG_C is expanded from...
unix/config/acx_pthread.m4:78: ACX_PTHREAD is expanded from...
configure.ac:295: the top level
configure.ac:295: warning: The macro `AC_TRY_LINK' is obsolete.
configure.ac:295: You should run autoupdate.
../../lib/autoconf/general.m4:2687: AC_TRY_LINK is expanded from...
unix/config/acx_pthread.m4:78: ACX_PTHREAD is expanded from...
configure.ac:295: the top level
configure.ac:295: warning: The macro `AC_LANG_RESTORE' is obsolete.
configure.ac:295: You should run autoupdate.
../../lib/autoconf/lang.m4:134: AC_LANG_RESTORE is expanded from...
unix/config/acx_pthread.m4:78: ACX_PTHREAD is expanded from...
configure.ac:295: the top level
configure.ac:302: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call
detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2590: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2606: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:639: AS_IF is expanded from...
../../lib/autoconf/general.m4:2031: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2052: AC_CACHE_CHECK is expanded from...
unix/config/ax_boost_thread.m4:32: AX_BOOST_THREAD is expanded from...
configure.ac:302: the top level
+ cat ./configure
+ sed -e s,configure.gnu  --help=recursive,& --srcdir=$ac_srcdir,g -e
s,\(cd \)\($ac_\)\(pop\)*\(dir\),\1"\2\3\4",g -e
s,$am_aux_dir/missing,\\"$am_aux_dir\\"/missing,g
+ mv -f ./configure.tmp ./configure
+ chmod +x ./configure
+ rm -f -r ./autom4te.cache


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.