POV-Ray : Newsgroups : povray.tools.poser : Suggestion for future Poseray version Server Time: 14 Dec 2018 15:42:40 GMT
  Suggestion for future Poseray version (Message 1 to 4 of 4)  
From: Thomas de Groot
Subject: Suggestion for future Poseray version
Date: 4 Feb 2015 12:33:28
Message: <54d21198@news.povray.org>
I view of the changes already foreshadowed in POV-Ray 3.71 alpha, it 
would be convenient to change backslash path separators into forward 
slash path separators when exporting image_map paths to POV-Ray. In the 
current alpha version a parse warning message is shown; I guess that in 
future it will become imperative.

-- 
Thomas


Post a reply to this message

From: Thomas de Groot
Subject: Re: Suggestion for future Poseray version
Date: 5 Feb 2015 08:22:53
Message: <54d3285d$1@news.povray.org>
On 4-2-2015 13:33, Thomas de Groot wrote:
> I view of the changes already foreshadowed in POV-Ray 3.71 alpha, it
> would be convenient to change backslash path separators into forward
> slash path separators when exporting image_map paths to POV-Ray. In the
> current alpha version a parse warning message is shown; I guess that in
> future it will become imperative.
>
Correction: in version 3.71 alpha a parse error is given - "Illegal 
escape sequence in string". So, it is already /imperative/ ;-)

-- 
Thomas


Post a reply to this message

From: clipka
Subject: Re: Suggestion for future Poseray version
Date: 5 Feb 2015 12:07:15
Message: <54d35cf3$1@news.povray.org>
Am 05.02.2015 um 09:22 schrieb Thomas de Groot:
> On 4-2-2015 13:33, Thomas de Groot wrote:
>> I view of the changes already foreshadowed in POV-Ray 3.71 alpha, it
>> would be convenient to change backslash path separators into forward
>> slash path separators when exporting image_map paths to POV-Ray. In the
>> current alpha version a parse warning message is shown; I guess that in
>> future it will become imperative.
>>
> Correction: in version 3.71 alpha a parse error is given - "Illegal
> escape sequence in string". So, it is already /imperative/ ;-)

.. unless you insert a "#version 3.70" directive ;)


Post a reply to this message

From: Thomas de Groot
Subject: Re: Suggestion for future Poseray version
Date: 5 Feb 2015 13:13:32
Message: <54d36c7c@news.povray.org>
On 5-2-2015 13:07, clipka wrote:
> Am 05.02.2015 um 09:22 schrieb Thomas de Groot:
>> On 4-2-2015 13:33, Thomas de Groot wrote:
>>> I view of the changes already foreshadowed in POV-Ray 3.71 alpha, it
>>> would be convenient to change backslash path separators into forward
>>> slash path separators when exporting image_map paths to POV-Ray. In the
>>> current alpha version a parse warning message is shown; I guess that in
>>> future it will become imperative.
>>>
>> Correction: in version 3.71 alpha a parse error is given - "Illegal
>> escape sequence in string". So, it is already /imperative/ ;-)
>
> .. unless you insert a "#version 3.70" directive ;)
>
Of course, but in the end it will be more satisfying to have unambiguous 
code.

-- 
Thomas


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.