POV-Ray : Newsgroups : povray.programming : povmodeler : Re: povmodeler Server Time
25 Feb 2024 00:42:22 EST (-0500)
  Re: povmodeler  
From: Dick Balaska
Date: 3 Nov 2019 01:29:39
Message: <5dbe65c3$1@news.povray.org>
On 11/2/19 9:53 PM, Bald Eagle wrote:
> 
> "simbad" <Han### [at] gmxde> wrote:
>> I did create a debian-10 package.
>> Could be downloaded here https://simulated-universe.de/povmodeler-0.1-Linux.deb
>>
>> This is my first try ever to create a debian package. It will evolve over time.
> 
> I opened it in Mint's Package Installer, and got:
> "Error: dependency is not satisfiable: libglx0"
> 
> I tried sudo apt-get install libglx0 (and libglx and libgl) but it couldn't find
> any such package to install.   So I'm not sure what I need to install or where
> to install it from...
> 
> then I tried this:
> 
> sudo dpkg -i povmodeler-0.1-Linux.deb
> [sudo] password for oem:
> Selecting previously unselected package povmodeler.
> (Reading database ... 288574 files and directories currently installed.)
> Preparing to unpack povmodeler-0.1-Linux.deb ...
> Unpacking povmodeler (0.1) ...
> dpkg: dependency problems prevent configuration of povmodeler:
>   povmodeler depends on libglx0; however:
>    Package libglx0 is not installed.
>   povmodeler depends on libopengl0; however:
>    Package libopengl0 is not installed.
>   povmodeler depends on libqt5core5a (>= 5.11.0~rc1); however:
>    Version of libqt5core5a:amd64 on system is 5.5.1+dfsg-16ubuntu7.6.
>   povmodeler depends on libqt5gui5 (>= 5.7.0); however:
>    Version of libqt5gui5:amd64 on system is 5.5.1+dfsg-16ubuntu7.6.
>   povmodeler depends on libqt5widgets5 (>= 5.11.0~rc1); however:
>    Version of libqt5widgets5:amd64 on system is 5.5.1+dfsg-16ubuntu7.6.
> 
> I'll work on it for a little while, but I'm trying this at the end of the day...
> :O
> 
> 

I have libglx0 and libopengl0 [1], but I'm not sure where they came 
from. AFAICT they are in the normal mint/ubuntu repos. The home page 
listed below contains just the source, not a .deb package.  The only 
custom repos in /etc/apt/sources.list.d point to my own stuff (like 
qtpovray).

The Qt >= 5.11 is problematic.  That is way too new to be in any debian 
distros. Baldy is Mint 19.1 with QT 5.5.  I am Mint 19.2 (newest 
version, 2 months old) and that is QT 5.9.

Simbad, my reading of
https://www.debian.org/doc/manuals/debmake-doc/ch08.en.html#cmake-single
says you ran some cmake command which generated the debian folder, then 
you ran something else to build the .deb.  You should edit the 
debian/control file and remove the versions from the dependencies and 
try to let the packager figure it out.
You run the risk of using a qt5 feature newer than 5.5, but it's a low 
risk.  I had a couple of issues solved like this:
https://github.com/dickbalaska/qtpovray/blob/qtpovray/qt/gui/editor/codeeditor.cpp#L114

qtpovray's control looks like this:
https://github.com/dickbalaska/qtpovray/blob/qtpovray/debian/control

I find it mush easier to keep the debian folder around as a native part 
of the source tree rather than continually recreating and editing them.

Another example is, your icons aren't quite right. These need to move:
hi16-app-kpovmodeler.png /usr/share/icons/hicolor/16x16/povmodeler.png
hi22-app-kpovmodeler.png /usr/share/icons/hicolor/22x22/povmodeler.png
hi32-app-kpovmodeler.png /usr/share/icons/hicolor/32x32/povmodeler.png
hi48-app-kpovmodeler.png /usr/share/icons/hicolor/48x48/povmodeler.png

and then in your povmodeler.desktop the icon reference is just 
povmodeler.  You can either hack debian/rules to move and rename them, 
like this:
https://github.com/dickbalaska/slyther-debian/blob/master/rules
or just reorg them in the source tree, and reference them normally.

---

[1] $ apt-cache show libglx0
Package: libglx0
Architecture: amd64
Version: 1.0.0-2ubuntu2.3
Multi-Arch: same
Priority: extra
Section: libs
Source: libglvnd
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubu### [at] listsubuntucom>
Original-Maintainer: Debian X Strike Force <deb### [at] listsdebianorg>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 90
Depends: libc6 (>= 2.14), libglvnd0 (= 1.0.0-2ubuntu2.3), libx11-6 (>= 
2:1.4.99.1), libglx-mesa0
Breaks: libgl1-mesa-glx (<< 18.0.5-0ubuntu0~18.04), libglvnd0 (<< 
0.2.999+git20170201-1)
Replaces: libgl1-mesa-glx (<< 18.0.5-0ubuntu0~18.04), libglvnd0 (<< 
0.2.999+git20170201-1)
Filename: pool/main/libg/libglvnd/libglx0_1.0.0-2ubuntu2.3_amd64.deb
Size: 28088
MD5sum: 312d48ae120aeba38800cf0eba14d139
SHA1: 65dfb7b0292b18c98710105fef352278df87c041
SHA256: 11d56b939271cac02b251dcc53630aec86aa66fc9433f3b63e3c6806580b20e8
Homepage: https://github.com/NVIDIA/libglvnd
Description-en: Vendor neutral GL dispatch library -- GLX support
  This is an implementation of the vendor-neutral dispatch layer for
  arbitrating OpenGL API calls between multiple vendors on a per-screen 
basis.
  .
  This package contains support for GLX.

-- 
dik
Rendered 22,077,619,200 of 40,928,716,800 pixels (53%)


Post a reply to this message

Copyright 2003-2023 Persistence of Vision Raytracer Pty. Ltd.