POV-Ray : Newsgroups : povray.pov4.discussion.general : Backwards Compatibility Server Time: 25 Jun 2019 19:47:30 GMT
  Backwards Compatibility (Message 1 to 1 of 1)  
From: Captain Jack
Subject: Backwards Compatibility
Date: 5 May 2009 21:10:01
Message: <web.4a00aa52b8569c901a0422150@news.povray.org>
I've been catching up on the threads in here, and I want to say that I like a
lot of the ideas I've seen with regard to a new SDL. I also appreciate the
importance of backward compatibility, as well as how much that hampers the
options formaking things more sophisticated.

What I wanted to suggest is that, when installed, there could be a configuration
for POV4 to point to a POV3 executable. When parsing a scene that either has a
#version directive (or however v4 will do it) or possibly if some clearly old
syntax is encountered, the program could abandon the parse, hand the file over
to the old executable, then intercept the results for any further processing
that v4 will be capable of.

I know there are bound to be some problems with confusing the renderer,
especially if v4 maintains any of the "self-modifying" flavor of the
conditional parsing that v3 supports; theoretically, it could even bail out on
part of an animation and not on another. However, this might be a way to allow
the new program to render older scenes without error, without having to bloat
the new POV.


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.