POV-Ray : Newsgroups : povray.object-collection : Should the POV-Ray version be included in the prereqs file? Server Time: 14 Dec 2018 00:18:25 GMT
  Should the POV-Ray version be included in the prereqs file? (Message 1 to 1 of 1)  
From: Cousin Ricky
Subject: Should the POV-Ray version be included in the prereqs file?
Date: 21 Jul 2012 04:10:00
Message: <web.500a2aa56550b66385de7b680@news.povray.org>
The Object Collection help says, "You should avoid prerequisites and
dependencies wherever possible, ..." but mentions "a specific version of
POV-Ray" as a possible dependency.

I cannot guarantee that any of my contributions will work with any POV-Ray
earlier than 3.5, and one of them works only with 3.6 or later.  My practice so
far has been to put an appropriate #version (usually 3.6) in my .inc files, but
(in keeping with common practice) to leave the prereqs blank.  Is there a
working assumption that the user will be using a reasonably recent version of
POV-Ray?

Nearly all of the objects in the collection have empty prereqs files, but I
cannot believe that all of them will work with POV-Ray 3.1 and older, given the
major syntax changes mentioned in the 3.5 documentation.  It seems that some
sort of unwritten assumption is already being made by the contributors.


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.