POV-Ray : Newsgroups : povray.newusers : Failed to running Server Time: 19 Dec 2018 14:08:22 GMT
  Failed to running (Message 1 to 5 of 5)  
From: 2762993256@qq com
Subject: Failed to running
Date: 24 Jul 2017 12:30:01
Message: <web.5975e71dbf879de2ae9fc6e00@news.povray.org>
Hello,respected experts&#65281;I am a new Chinese pov-ray user so I hope you can
forgive my poor English and fool problem.
Every time I try to run the povray-3.7-stable in vs2010,it will be a error:

error C3861: “_mm_nmacc_pd”(and so many founctions like that,for example
"_mm_macc_sd","_mm_macc_pd","_mm_nmacc_sd"): can't find identifier.

I had use many ways to resolve this error,but I failed.So I want to get a right
answer through this forum.

Thank you very much!


Post a reply to this message

From: clipka
Subject: Re: Failed to running
Date: 24 Jul 2017 18:39:42
Message: <59763eee@news.povray.org>
Am 24.07.2017 um 14:26 schrieb 276### [at] qqcom:
> Hello,respected experts&#65281;I am a new Chinese pov-ray user so I hope you can
> forgive my poor English and fool problem.
> Every time I try to run the povray-3.7-stable in vs2010,it will be a error:
> 
> error C3861: “_mm_nmacc_pd”(and so many founctions like that,for example
> "_mm_macc_sd","_mm_macc_pd","_mm_nmacc_sd"): can't find identifier.
> 
> I had use many ways to resolve this error,but I failed.So I want to get a right
> answer through this forum.
> 
> Thank you very much!

Please try changing the following code in `vfe/win/compilers/msvc.h`
(around line 40):

    #undef USE_AVX_FMA4_FOR_NOISE
    #if _MSC_VER >= 1600
      #define USE_AVX_FMA4_FOR_NOISE
    #endif

to:

    #undef USE_AVX_FMA4_FOR_NOISE
    #if _MSC_FULL_VER >= 160040219
      #define USE_AVX_FMA4_FOR_NOISE
    #endif


Post a reply to this message

From: clipka
Subject: Re: Failed to running
Date: 24 Jul 2017 18:43:19
Message: <59763fc7$1@news.povray.org>
Am 24.07.2017 um 14:26 schrieb 276### [at] qqcom:
> Hello,respected experts&#65281;I am a new Chinese pov-ray user so I hope you can
> forgive my poor English and fool problem.
> Every time I try to run the povray-3.7-stable in vs2010,it will be a error:

As a side note: If you're new to POV-Ray, why would you want to compile
your own POV-Ray for Windows binaries?


Post a reply to this message

From: 2762993256@qq com
Subject: Re: Failed to running
Date: 25 Jul 2017 01:25:01
Message: <web.59769d0d7db639ec2c1c1d8c0@news.povray.org>
clipka <ano### [at] anonymousorg> wrote:
> Am 24.07.2017 um 14:26 schrieb 276### [at] qqcom:
> > Hello,respected experts&#65281;I am a new Chinese pov-ray user so I hope you can
> > forgive my poor English and fool problem.
> > Every time I try to run the povray-3.7-stable in vs2010,it will be a error:
> >
> > error C3861: “_mm_nmacc_pd”(and so many founctions like that,for example
> > "_mm_macc_sd","_mm_macc_pd","_mm_nmacc_sd"): can't find identifier.
> >
> > I had use many ways to resolve this error,but I failed.So I want to get a right
> > answer through this forum.
> >
> > Thank you very much!
>
> Please try changing the following code in `vfe/win/compilers/msvc.h`
> (around line 40):
>
>     #undef USE_AVX_FMA4_FOR_NOISE
>     #if _MSC_VER >= 1600
>       #define USE_AVX_FMA4_FOR_NOISE
>     #endif
>
> to:
>
>     #undef USE_AVX_FMA4_FOR_NOISE
>     #if _MSC_FULL_VER >= 160040219
>       #define USE_AVX_FMA4_FOR_NOISE
>     #endif


Thank you very much!I have already run successfully.


Post a reply to this message

From: clipka
Subject: Re: Failed to running
Date: 25 Jul 2017 06:09:04
Message: <5976e080$1@news.povray.org>
Am 25.07.2017 um 03:21 schrieb 276### [at] qqcom:
> Thank you very much!I have already run successfully.

Glad to hear that.

If your computer's CPU supports AVX and FMA4 (most contemporary AMD CPUs
do, except the new Ryzen[*]; Intel CPUs don't), I recommend installing
Visual Studio 2010 Service Pack 1, as it will produce binaries that run
faster on such CPUs. (The suggested fix actually disables some
optimizations for such CPUs, which require VS 2010 SP1 or later but were
erroneously enabled for VS 2010 without SP1 as well.)

Or, better yet, install VS 2015 Community Edition (unless you're still
using Windows XP), which should generate binaries that run even faster.


[*Strictly speaking Ryzen also seems to support FMA4, but this is not
advertised via CPUID, so POV-Ray can't make use of it.]


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.