POV-Ray : Newsgroups : povray.macintosh : povray 3.6 on Snow Leopard / X11 Server Time: 20 Jun 2019 19:15:25 GMT
  povray 3.6 on Snow Leopard / X11 (Message 1 to 8 of 8)  
From: lainal
Subject: povray 3.6 on Snow Leopard / X11
Date: 15 Aug 2011 00:25:00
Message: <web.4e4865211f72b142975cc8f30@news.povray.org>
Gents,

For those interested in, I managed to compile povray 3.6 on Mac OS 10.8 since I
didn't found any working version on the Web (PPC distribution is hitting Rosetta
issues). Hereafter the way I went in 7 steps:
0 - Download the source code for Linux / Generic and unarchive
1 - hack all 3 "configure.ac" files to add "foreign" in the parameters of the
macro "AM_INIT_AUTOMAKE"  (some GNU distribution mandatory files are missing)
2 - create the configure script with autoreconf -i
3 - edit the top "configure" and add at the 1st active line the following:
      ac_cv_prog_egrep=/usr/bin/egrep
4 - Configure with:
      CFLAGS="-m32" CXXFLAGS="-m32" \
      ./configure COMPILED_BY="<your mail address>" --with-x
5 - make
6 - make install (possibly preceded by su)

I also compiled with X disabled without noticing performance differences, so
better keep it :-)

Example of run:
$ povray ~/Downloads/povray-3.6.1/scenes/advanced/landscape.pov
Persistence of Vision(tm) Ray Tracer Version 3.6.1 (g++ 4.2.1 @
 i686-apple-darwin10.8.0)
This is an unofficial version compiled by:
 dla### [at] yahoocom
 The POV-Ray Team(tm) is not responsible for supporting this version.
[...]
Peak memory used:           6299545 bytes
Total Scene Processing Times
  Parse Time:    0 hours  0 minutes  1 seconds (1 seconds)
  Photon Time:   0 hours  0 minutes  0 seconds (0 seconds)
  Render Time:   0 hours  0 minutes 15 seconds (15 seconds)
  Total Time:    0 hours  0 minutes 16 seconds (16 seconds)

Enjoy!

- Dominique


Post a reply to this message

From: TSGM
Subject: Re: povray 3.6 on Snow Leopard / X11
Date: 13 Oct 2011 01:00:01
Message: <web.4e9637d4c3cac33331848b5f0@news.povray.org>
"lainal" <dla### [at] yahoocom> wrote:
> Gents,
>
> For those interested in, I managed to compile povray 3.6 on Mac OS 10.8 since I
> didn't found any working version on the Web (PPC distribution is hitting Rosetta
> issues). Hereafter the way I went in 7 steps:
> 0 - Download the source code for Linux / Generic and unarchive
> 1 - hack all 3 "configure.ac" files to add "foreign" in the parameters of the
> macro "AM_INIT_AUTOMAKE"  (some GNU distribution mandatory files are missing)
> 2 - create the configure script with autoreconf -i
> 3 - edit the top "configure" and add at the 1st active line the following:
>       ac_cv_prog_egrep=/usr/bin/egrep
> 4 - Configure with:
>       CFLAGS="-m32" CXXFLAGS="-m32" \
>       ./configure COMPILED_BY="<your mail address>" --with-x
> 5 - make
> 6 - make install (possibly preceded by su)
>

Dear Dominique,

I too am running OSX Lion and I'm trying to install POVRay. Unfortunately, I'm
quite clueless about Unix, so I'm hoping you (or someone else) can clarify your
instructions. For example, I'm already lost on step 1 (what configure.ac files?)

I would most appreciate it if you could guide me through the installation and
compilation process, on the assumption that I know little about using make files
or unix in general.

Thanks!


Post a reply to this message

From: lainal
Subject: Re: povray 3.6 on Snow Leopard / X11
Date: 26 Oct 2011 06:35:00
Message: <web.4ea7a7ffc3cac3331fd128320@news.povray.org>
"TSGM" <nomail@nomail> wrote:
> "lainal" <dla### [at] yahoocom> wrote:
> > Gents,
> >
> > For those interested in, I managed to compile povray 3.6 on Mac OS 10.8 since I
> > didn't found any working version on the Web (PPC distribution is hitting Rosetta
> > issues). Hereafter the way I went in 7 steps:
> > 0 - Download the source code for Linux / Generic and unarchive
> > 1 - hack all 3 "configure.ac" files to add "foreign" in the parameters of the
> > macro "AM_INIT_AUTOMAKE"  (some GNU distribution mandatory files are missing)
> > 2 - create the configure script with autoreconf -i
> > 3 - edit the top "configure" and add at the 1st active line the following:
> >       ac_cv_prog_egrep=/usr/bin/egrep
> > 4 - Configure with:
> >       CFLAGS="-m32" CXXFLAGS="-m32" \
> >       ./configure COMPILED_BY="<your mail address>" --with-x
> > 5 - make
> > 6 - make install (possibly preceded by su)
> >
>
> Dear Dominique,
>
> I too am running OSX Lion and I'm trying to install POVRay. Unfortunately, I'm
> quite clueless about Unix, so I'm hoping you (or someone else) can clarify your
> instructions. For example, I'm already lost on step 1 (what configure.ac files?)
>
> I would most appreciate it if you could guide me through the installation and
> compilation process, on the assumption that I know little about using make files
> or unix in general.
>
> Thanks!

OK. I was a little too quick I guess. Sorry for that. The distrib to download is
at this location:
http://www.povray.org/redirect/www.povray.org/ftp/pub/povray/Official/Unix/povray-3.6.tar.bz2

I guess it will go in Download. Then you open a terminal, go to this directory.

1. Unarchive: "tar xjf povray-3.6.tar.bz2" and go to the source directory
(povray-3.6.1).

2. There are three "configure.ac" files in the sources tree:
......./configure.ac
......./libraries/png/configure.ac
......./libraries/zlib/configure.ac
You have to edit them, find the AM_INIT_AUTOMAKE macros. It should look like:

AM_INIT_AUTOMAKE([1.7 ...])

You have to add "foreign". Then it should look like:

AM_INIT_AUTOMAKE([foreign 1.7 ...])

This for all three files.

3. Then from the top source directory (povray-3.6.1 currently), you type
"autoreconf -i" and you wait a little bit. After a while, there's a "configure"
script which has been created. You have to edit it and add the line as
explained. For me, after adding the line, it looks like:

...........
## --------------------- ##
## M4sh Initialization.  ##
## --------------------- ##

ac_cv_prog_egrep=/usr/bin/egrep

# Be more Bourne compatible
...........

4. The rest is straightforward. Still from the top source directory, you type:

CFLAGS="-m32" CXXFLAGS="-m32" ./configure COMPILED_BY="email" --with-x

Then you type "make" and you wait for a while.

If no errors occur, then "make install" and that's it.

Happy install !

- Dominique


Post a reply to this message

From: atirtil
Subject: Re: povray 3.6 on Snow Leopard / X11
Date: 21 Dec 2011 20:25:00
Message: <web.4ef23f9dc3cac333491f7b540@news.povray.org>
Dear Dominique,

I tried out your last reply. Everything went well until the " make " process. I
had this error :
""""""""""""""""""""""""""""""""""""""""""""""""""""""""
if [ nodso != nodso ]; then \
     make - nodso; \
 else \
     true; \
 fi
make[2]: Nothing to be done for `all-am'.
Making install in source
Making install in base
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
Making install in frontend
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
Making install in unix
/bin/sh ../config/mkinstalldirs /usr/local/bin
  /usr/bin/install -c povray /usr/local/bin/povray
install: /usr/local/bin/povray: Permission denied
make[2]: *** [install-binPROGRAMS] Error 1
make[1]: *** [install-am] Error 2
make: *** [install-recursive] Error 1
"""""""""""""""""""""""""""""""""""""""""""""""""""""""
I would really appreciate your help,

thank you



"lainal" <dla### [at] yahoocom> wrote:
> "TSGM" <nomail@nomail> wrote:
> > "lainal" <dla### [at] yahoocom> wrote:
> > > Gents,
> > >
> > > For those interested in, I managed to compile povray 3.6 on Mac OS 10.8 since I
> > > didn't found any working version on the Web (PPC distribution is hitting Rosetta
> > > issues). Hereafter the way I went in 7 steps:
> > > 0 - Download the source code for Linux / Generic and unarchive
> > > 1 - hack all 3 "configure.ac" files to add "foreign" in the parameters of the
> > > macro "AM_INIT_AUTOMAKE"  (some GNU distribution mandatory files are missing)
> > > 2 - create the configure script with autoreconf -i
> > > 3 - edit the top "configure" and add at the 1st active line the following:
> > >       ac_cv_prog_egrep=/usr/bin/egrep
> > > 4 - Configure with:
> > >       CFLAGS="-m32" CXXFLAGS="-m32" \
> > >       ./configure COMPILED_BY="<your mail address>" --with-x
> > > 5 - make
> > > 6 - make install (possibly preceded by su)
> > >
> >
> > Dear Dominique,
> >
> > I too am running OSX Lion and I'm trying to install POVRay. Unfortunately, I'm
> > quite clueless about Unix, so I'm hoping you (or someone else) can clarify your
> > instructions. For example, I'm already lost on step 1 (what configure.ac files?)
> >
> > I would most appreciate it if you could guide me through the installation and
> > compilation process, on the assumption that I know little about using make files
> > or unix in general.
> >
> > Thanks!
>
> OK. I was a little too quick I guess. Sorry for that. The distrib to download is
> at this location:
>
http://www.povray.org/redirect/www.povray.org/ftp/pub/povray/Official/Unix/povray-3.6.tar.bz2
>
> I guess it will go in Download. Then you open a terminal, go to this directory.
>
> 1. Unarchive: "tar xjf povray-3.6.tar.bz2" and go to the source directory
> (povray-3.6.1).
>
> 2. There are three "configure.ac" files in the sources tree:
> ......./configure.ac
> ......./libraries/png/configure.ac
> ......./libraries/zlib/configure.ac
> You have to edit them, find the AM_INIT_AUTOMAKE macros. It should look like:
>
> AM_INIT_AUTOMAKE([1.7 ...])
>
> You have to add "foreign". Then it should look like:
>
> AM_INIT_AUTOMAKE([foreign 1.7 ...])
>
> This for all three files.
>
> 3. Then from the top source directory (povray-3.6.1 currently), you type
> "autoreconf -i" and you wait a little bit. After a while, there's a "configure"
> script which has been created. You have to edit it and add the line as
> explained. For me, after adding the line, it looks like:
>
> ...........
> ## --------------------- ##
> ## M4sh Initialization.  ##
> ## --------------------- ##
>
> ac_cv_prog_egrep=/usr/bin/egrep
>
> # Be more Bourne compatible
> ...........
>
> 4. The rest is straightforward. Still from the top source directory, you type:
>
> CFLAGS="-m32" CXXFLAGS="-m32" ./configure COMPILED_BY="email" --with-x
>
> Then you type "make" and you wait for a while.
>
> If no errors occur, then "make install" and that's it.
>
> Happy install !
>
> - Dominique


Post a reply to this message

From: Warp
Subject: Re: povray 3.6 on Snow Leopard / X11
Date: 22 Dec 2011 17:29:18
Message: <4ef368ee@news.povray.org>
atirtil <nomail@nomail> wrote:
> Making install in unix
> /bin/sh ../config/mkinstalldirs /usr/local/bin
>   /usr/bin/install -c povray /usr/local/bin/povray
> install: /usr/local/bin/povray: Permission denied
> make[2]: *** [install-binPROGRAMS] Error 1
> make[1]: *** [install-am] Error 2
> make: *** [install-recursive] Error 1

  If "make" succeeded, then you don't have to proceed with "make install".
The executable will have been built already (I don't remember if it's in
the same directory as the Makefile or in one of the subdirectories). You
can run it directly, if you want.

  (Note that if you want to define some default settings and the path
to the standard include files, you'll have to manually create a
.povray/3.7/povray.ini file in your home directory.)

-- 
                                                          - Warp


Post a reply to this message

From: eeeeaaii
Subject: Re: povray 3.6 on Snow Leopard / X11
Date: 1 Mar 2012 18:55:01
Message: <web.4f4fc588c3cac333fda0e8490@news.povray.org>
"lainal" <dla### [at] yahoocom> wrote:
> Gents,
>
> For those interested in, I managed to compile povray 3.6 on Mac OS 10.8 since I
> didn't found any working version on the Web (PPC distribution is hitting Rosetta
> issues). Hereafter the way I went in 7 steps:
> 0 - Download the source code for Linux / Generic and unarchive
> 1 - hack all 3 "configure.ac" files to add "foreign" in the parameters of the
> macro "AM_INIT_AUTOMAKE"  (some GNU distribution mandatory files are missing)
> 2 - create the configure script with autoreconf -i
> 3 - edit the top "configure" and add at the 1st active line the following:
>       ac_cv_prog_egrep=/usr/bin/egrep
> 4 - Configure with:
>       CFLAGS="-m32" CXXFLAGS="-m32" \
>       ./configure COMPILED_BY="<your mail address>" --with-x
> 5 - make
> 6 - make install (possibly preceded by su)
>
> I also compiled with X disabled without noticing performance differences, so
> better keep it :-)
>
> Example of run:
> $ povray ~/Downloads/povray-3.6.1/scenes/advanced/landscape.pov
> Persistence of Vision(tm) Ray Tracer Version 3.6.1 (g++ 4.2.1 @
>  i686-apple-darwin10.8.0)
> This is an unofficial version compiled by:
>  dla### [at] yahoocom
>  The POV-Ray Team(tm) is not responsible for supporting this version.
> [...]
> Peak memory used:           6299545 bytes
> Total Scene Processing Times
>   Parse Time:    0 hours  0 minutes  1 seconds (1 seconds)
>   Photon Time:   0 hours  0 minutes  0 seconds (0 seconds)
>   Render Time:   0 hours  0 minutes 15 seconds (15 seconds)
>   Total Time:    0 hours  0 minutes 16 seconds (16 seconds)
>
> Enjoy!
>
> - Dominique


I'm having a pretty weird problem.  I am able to compile and run the program,
but it performs weirdly: spheres that are clearly there are never intersected
with the rays from the light sources, etc.  I put in some time putting trace
statements in the code and I have actually narrowed it down to a compiler bug in
the llvm compiler.  Works fine on my mac with the older version of XCode but the
LLVM compiler is translating the C code into something wrong, such that memory
gets trashed and variables get scrambled, etc.  Wondering if anyone else had
this problem.


Post a reply to this message

From: cjaramillo
Subject: Re: povray 3.6 on Snow Leopard / X11
Date: 13 Jul 2012 20:30:01
Message: <web.50008454c3cac333d568c8340@news.povray.org>
"lainal" <dla### [at] yahoocom> wrote:
> "TSGM" <nomail@nomail> wrote:
> > "lainal" <dla### [at] yahoocom> wrote:
> > > Gents,
> > >
> > > For those interested in, I managed to compile povray 3.6 on Mac OS 10.8 since I
> > > didn't found any working version on the Web (PPC distribution is hitting Rosetta
> > > issues). Hereafter the way I went in 7 steps:
> > > 0 - Download the source code for Linux / Generic and unarchive
> > > 1 - hack all 3 "configure.ac" files to add "foreign" in the parameters of the
> > > macro "AM_INIT_AUTOMAKE"  (some GNU distribution mandatory files are missing)
> > > 2 - create the configure script with autoreconf -i
> > > 3 - edit the top "configure" and add at the 1st active line the following:
> > >       ac_cv_prog_egrep=/usr/bin/egrep
> > > 4 - Configure with:
> > >       CFLAGS="-m32" CXXFLAGS="-m32" \
> > >       ./configure COMPILED_BY="<your mail address>" --with-x
> > > 5 - make
> > > 6 - make install (possibly preceded by su)
> > >
> >
> > Dear Dominique,
> >
> > I too am running OSX Lion and I'm trying to install POVRay. Unfortunately, I'm
> > quite clueless about Unix, so I'm hoping you (or someone else) can clarify your
> > instructions. For example, I'm already lost on step 1 (what configure.ac files?)
> >
> > I would most appreciate it if you could guide me through the installation and
> > compilation process, on the assumption that I know little about using make files
> > or unix in general.
> >
> > Thanks!
>
> OK. I was a little too quick I guess. Sorry for that. The distrib to download is
> at this location:
>
http://www.povray.org/redirect/www.povray.org/ftp/pub/povray/Official/Unix/povray-3.6.tar.bz2
>
> I guess it will go in Download. Then you open a terminal, go to this directory.
>
> 1. Unarchive: "tar xjf povray-3.6.tar.bz2" and go to the source directory
> (povray-3.6.1).
>
> 2. There are three "configure.ac" files in the sources tree:
> ......./configure.ac
> ......./libraries/png/configure.ac
> ......./libraries/zlib/configure.ac
> You have to edit them, find the AM_INIT_AUTOMAKE macros. It should look like:
>
> AM_INIT_AUTOMAKE([1.7 ...])
>
> You have to add "foreign". Then it should look like:
>
> AM_INIT_AUTOMAKE([foreign 1.7 ...])
>
> This for all three files.
>
> 3. Then from the top source directory (povray-3.6.1 currently), you type
> "autoreconf -i" and you wait a little bit. After a while, there's a "configure"
> script which has been created. You have to edit it and add the line as
> explained. For me, after adding the line, it looks like:
>
> ...........
> ## --------------------- ##
> ## M4sh Initialization.  ##
> ## --------------------- ##
>
> ac_cv_prog_egrep=/usr/bin/egrep
>
> # Be more Bourne compatible
> ...........
>
> 4. The rest is straightforward. Still from the top source directory, you type:
>
> CFLAGS="-m32" CXXFLAGS="-m32" ./configure COMPILED_BY="email" --with-x
>
> Then you type "make" and you wait for a while.
>
> If no errors occur, then "make install" and that's it.
>
> Happy install !
>
> - Dominique

I got the following error after trying "sudo make install":
make[2]: *** [install-nobase_povlibSCRIPTS] Error 1
make[1]: *** [install-am] Error 2
make: *** [install-recursive] Error 1

Any hints would be appreciated.

Carlos


Post a reply to this message

From: Aaron
Subject: Re: povray 3.6 on Snow Leopard / X11
Date: 21 Feb 2013 14:35:01
Message: <web.51263044c3cac333d734facb0@news.povray.org>
On Mac OS X, you can install povray 3.7.0RC6 quite painlessly with Homebrew (
http://mxcl.github.com/homebrew/ ).  After installing homebrew, just enter the
following from the terminal:

  brew install povray

That will download the source, patch it for the mac, build and install it.  You
can then keep it up to date with the usual brew commands (brew update, brew
upgrade, etc).

Cheers!


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.