POV-Ray : Newsgroups : povray.macintosh : Pov-ray 3.8 or 3.7.1 Command Line for Macintosh : Re: Pov-ray 3.8 or 3.7.1 Command Line for Macintosh Server Time: 26 Jun 2019 19:53:48 GMT
  Re: Pov-ray 3.8 or 3.7.1 Command Line for Macintosh  
From: clipka
Date: 22 Feb 2019 10:18:00
Am 22.02.2019 um 10:37 schrieb clipka:

>> vfe.cpp:612:35: error: declaration of ‘virtual
>> vfe::VirtualFrontEnd::~VirtualFrontEnd() noexcept (false)’ has a 
>> different
>> exception specifier
>>   VirtualFrontEnd::~VirtualFrontEnd()
>>                                     ^
>> In file included from vfe.cpp:43:0:
>> vfe.h:222:15: error: from previous declaration ‘virtual
>> vfe::VirtualFrontEnd::~VirtualFrontEnd() noexcept (true)’
>>         virtual ~VirtualFrontEnd() ;
>>                 ^
>> make[2]: *** [vfe.o] Error 1
>> make[1]: *** [all-recursive] Error 1
>> make: *** [all] Error 2
> 
> Now this looks like an actual issue in the POV-Ray source code, and I'll 
> look into it.

I'm not exactly sure why this is happening; can you try changing the 
lines in question to

     VirtualFrontEnd::~VirtualFrontEnd() noexcept

and

     virtual ~VirtualFrontEnd() noexcept;

respectively and let me know what that does?


BTW, what version of g++ are you using now?


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.