POV-Ray : Newsgroups : povray.macintosh : Pov-ray 3.8 or 3.7.1 Command Line for Macintosh : Re: Pov-ray 3.8 or 3.7.1 Command Line for Macintosh Server Time: 18 Jun 2019 04:47:16 GMT
  Re: Pov-ray 3.8 or 3.7.1 Command Line for Macintosh  
From: clipka
Date: 21 Feb 2019 07:54:26
Am 21.02.2019 um 04:59 schrieb Jake:

>> https://github.com/POV-Ray/povray/releases/tag/v3.8.0-alpha.10013324
...
> As for this version, I can run the same configure command as above without the
> freetype flag and the configure program runs with no issues; however, running
> 'make check' produces the following error:
...
> g++: warning: couldnât understand kern.osversion â17.7.0
...

> This then loops for too many times for me to count before eventually failing to
> install.

Does it fail to "make install", does it fail to "make check", or does it 
even fail to "make"?

You've only quoted warning messages, but in case of a failure you should 
also get some genuine error messages; can you post those?

> If you have any ideas as to what could fix this I'd greatly appreciate it.

According to the internerds, the warning messages you get seem to 
indicate that your development tools are outdated; people suggest 
updating those, and in that context the followng commands are mentioned 
(either of these may work):

     xcode-select --install

     brew upgrade gcc

     brew upgrade gcc49

(Presumably the `49` in `gcc49` is a version number so you may need to 
adapt this to your case.)

Also, you seem to be using gcc, while we're using clang in our tests 
instead, which to the best of my knowledge is the "native" C/C++ 
compiler on Mac OS X. (IIRC we did have trouble getting gcc to work, too.)

You should be able to set this up by invoking

     export CXX=clang++

before running the `./configure` script. Alternatively, I think it 
should also be possible to pass `CXX=clang++` as a parameter to the 
`./configure` script.


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.