POV-Ray : Newsgroups : povray.general : Ignore .ini Errorrs in 3.7 : Re: Ignore .ini Errorrs in 3.7 Server Time
29 May 2023 11:15:09 EDT (-0400)
  Re: Ignore .ini Errorrs in 3.7  
From: Thorsten Froehlich
Date: 1 Oct 2018 15:50:00
Message: <web.5bb279994802201c132bb8d00@news.povray.org>
clipka <ano### [at] anonymousorg> wrote:
> Am 01.10.2018 um 18:01 schrieb Thorsten Froehlich:
>
> >> The INI file option was removed entirely in POV-Ray v3.7 when it should
> >> have been just marked as obsoleve. I'm working on a fix.
> >
> > It was made obsolete in 3.6 (or maybe even 3.5) and removed in 3.7. [...]
> > It is not a bug, but intentional design that hasn't
> > bothered anybody in a wopping 14 years...
>
> Probably as intentional a design decision as removing `Buffer_Output`
> and `Buffer_Size` - a change that was revised by Chris just 10 days
> later, presumably because people did complain.

No, because those two were still in the 3.6 documentation. Radiosity was
obsolete in 3.5 already. And the removal is not all that unusual. Halo was
removed as a scene language feature in 3.1 without backward compatibility, btw.

Radiosity was moved to SDL control in 3.5 together with photons, making both
consistent. And to judge that it was unintentional or a problem to remove in 3.7
by a single report in 14 years is more than odd...

Thorsten


Post a reply to this message

Copyright 2003-2023 Persistence of Vision Raytracer Pty. Ltd.