POV-Ray : Newsgroups : povray.bugreports : parametric goes wrong Server Time: 18 Jun 2019 07:14:53 GMT
  parametric goes wrong (Message 1 to 3 of 3)  
From: MidiPlay
Subject: parametric goes wrong
Date: 17 Jul 2015 10:20:00
Message: <web.55a8d672c13c7a748db64fec0@news.povray.org>
I'm using "parametric" to generate the surface of a cylinder, and it's being
displayed with bits missing.
----
#include "colors.inc"
background { rgb 0.05 }
light_source { <0,+10000,0> rgb 1 }

parametric
{
    function { 10 * (       0.5 * sin(v)) }
    function { 10 * ( 1   + 0.5 * cos(v)) }
    function { u }
    < -9, -pi/2 >, < 0, +pi/2 >
    contained_by { sphere { 0, 20 } }
    texture { pigment { rgbft < 0.5,  0,  0,  0.5, 0 > } }
    interior_texture { pigment { rgbft < 0, 0.5, 0, 0.5, 0 > } }
}
camera
{
    orthographic
    location < -5555, 5555, -7777 >
    angle 0.25
    look_at 0
}
----
If I move the camera higher to location < -5555, 15555, -7777 > then it's
displayed correctly.  What's going on?


Post a reply to this message

From: James Holsenback
Subject: Re: parametric goes wrong
Date: 17 Jul 2015 14:54:15
Message: <55a91717$1@news.povray.org>
On 07/17/2015 06:18 AM, MidiPlay wrote:
> I'm using "parametric" to generate the surface of a cylinder, and it's being
> displayed with bits missing.
> ----
> #include "colors.inc"
> background { rgb 0.05 }
> light_source { <0,+10000,0> rgb 1 }
>
> parametric
> {
>      function { 10 * (       0.5 * sin(v)) }
>      function { 10 * ( 1   + 0.5 * cos(v)) }
>      function { u }
>      < -9, -pi/2 >, < 0, +pi/2 >
>      contained_by { sphere { 0, 20 } }
>      texture { pigment { rgbft < 0.5,  0,  0,  0.5, 0 > } }
>      interior_texture { pigment { rgbft < 0, 0.5, 0, 0.5, 0 > } }
> }
> camera
> {
>      orthographic
>      location < -5555, 5555, -7777 >
>      angle 0.25
>      look_at 0
> }
> ----
> If I move the camera higher to location < -5555, 15555, -7777 > then it's
> displayed correctly.  What's going on?

max_gradient 1.3 just after contained_by fixes it, however in playing 
around with it i discovered that a value smaller than 1.2-e05 (1.19e0-5) 
causes a segmentation fault when using the accuracy parameter:

Segmentation fault 196608

same place for:
ash@aries:~/POV-Ray/Source $ uberpov --version
UberPOV 1.37.1.0

ash@aries:~/POV-Ray/Source $ povray --version
POV-Ray 3.7.1-alpha.8141620.unofficial


Post a reply to this message

From: clipka
Subject: Re: parametric goes wrong
Date: 31 Jul 2015 17:26:00
Message: <55bbafa8$1@news.povray.org>
Am 17.07.2015 um 16:54 schrieb James Holsenback:

> max_gradient 1.3 just after contained_by fixes it, however in playing
> around with it i discovered that a value smaller than 1.2-e05 (1.19e0-5)
> causes a segmentation fault when using the accuracy parameter:
>
> Segmentation fault 196608
>
> same place for:
> ash@aries:~/POV-Ray/Source $ uberpov --version
> UberPOV 1.37.1.0
>
> ash@aries:~/POV-Ray/Source $ povray --version
> POV-Ray 3.7.1-alpha.8141620.unofficial

Can you rephrase the "playing around with it" in terms of a small scene 
file? ;)


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.