POV-Ray : Newsgroups : povray.beta-test : problem with installing latest 'development build' Server Time: 30 Mar 2017 08:51:17 GMT
  problem with installing latest 'development build' (Message 1 to 8 of 8)  
From: Kenneth
Subject: problem with installing latest 'development build'
Date: 5 Feb 2016 09:55:00
Message: <web.56b4703fb1b68e033c457550@news.povray.org>
I just tried (several times) to download and install the Win32 sse2 version of
the latest 'development build' from Github (onto my older Windows 32-bit XP
machine)...

v3.7.1-alpha.8451792+av100

but after placing the 7zip-extracted pvengine32-sse2 file in v3.7's 'bin'
folder, it doesn't run at all. I get the Windows error message,

"C\Program Files\POV-Ray\v3.7\bin\pvengine-32sse2.exe is not a valid Win32
application"

My set-up worked fine with the previous development build, but not this one.
(Yes, I've 'hidden' v3.7's *original* pvengine32-sse2 file in a different dummy
folder.) I honestly have no idea what I'm doing wrong, if anything. Could there
be a problem with the file? I'm curious to know if anyone else has run into this
situation.


Post a reply to this message

From: Thomas de Groot
Subject: Re: problem with installing latest 'development build'
Date: 5 Feb 2016 12:36:49
Message: <56b49761$1@news.povray.org>
On 5-2-2016 10:49, Kenneth wrote:
> "C\Program Files\POV-Ray\v3.7\bin\pvengine-32sse2.exe is not a valid Win32
> application"

Have you tried to change the name to: pvengine.exe  ?


-- 
Thomas


Post a reply to this message

From: Kenneth
Subject: Re: problem with installing latest 'development build'
Date: 5 Feb 2016 13:15:00
Message: <web.56b49f31c6b49ec833c457550@news.povray.org>
Thomas de Groot <tho### [at] degrootorg> wrote:
> On 5-2-2016 10:49, Kenneth wrote:
> > "C\Program Files\POV-Ray\v3.7\bin\pvengine-32sse2.exe is not a valid Win32
> > application"
>
> Have you tried to change the name to: pvengine.exe  ?
>

No, because I *think* that would confuse POV-Ray. As far as I understand (and
from looking in my v3.7 'bin' folder), my *original* v3.7.0 download installed
*all* (3) versions of the engine-- pvengine, pvengine-sse2 and also pvengine64.
Changing the newly-downloaded 'pvengine-sse2.exe' to 'pvengine.exe' might cause
some strange behavior, as there would then be two identically-named apps in that
folder. (Of course, I could 'hide' the original pvengine file and then try your
suggestion; I'll see what happens and report back...)


Post a reply to this message

From: Kenneth
Subject: Re: problem with installing latest 'development build'
Date: 5 Feb 2016 13:30:01
Message: <web.56b4a2f4c6b49ec833c457550@news.povray.org>
"Kenneth" <kdw### [at] gmailcom> wrote:
> Thomas de Groot <tho### [at] degrootorg> wrote:

> >
> > Have you tried to change the name to: pvengine.exe  ?
> >
>
> ...I could 'hide' the original pvengine file and then try your
> suggestion; I'll see what happens and report back...)

Nope, no luck. I still get the error message. I've tried three downloads now.

The problem is strange because the previous development build's sse2 engine
worked just fine (as does my *original* 3.7.0 sse2 engine.)  Unfortunately for
me (well, temporarily unfortunate), I discarded the previous development
build... which was working... :-(


Post a reply to this message

From: clipka
Subject: Re: problem with installing latest 'development build'
Date: 5 Feb 2016 17:39:53
Message: <56b4de69$1@news.povray.org>
Am 05.02.2016 um 14:27 schrieb Kenneth:
> "Kenneth" <kdw### [at] gmailcom> wrote:
>> Thomas de Groot <tho### [at] degrootorg> wrote:
> 
>>>
>>> Have you tried to change the name to: pvengine.exe  ?
>>>
>>
>> ...I could 'hide' the original pvengine file and then try your
>> suggestion; I'll see what happens and report back...)
> 
> Nope, no luck. I still get the error message. I've tried three downloads now.
> 
> The problem is strange because the previous development build's sse2 engine
> worked just fine (as does my *original* 3.7.0 sse2 engine.)  Unfortunately for
> me (well, temporarily unfortunate), I discarded the previous development
> build... which was working... :-(

Can you let me know which build that "previous" development build was?


Apparently, Visual Studio 2012 or higher no longer support Windows XP as
a target platform. We're using VS 2015 to generate the development
builds, because that's the Visual Studio version provided by the
automated build service we're employing.

The service also has earlier build tools installed, which theoretically
should make it possible to compile and link with the VS 2010 toolset,
but in practice that leads to failures trying to build the 64 bit version.

I'll see whether we can use the VS 2010 toolset for the 32 bit versions
only.

For now, the latest development build to run on XP is probably this one
(from the semi-official series):

https://github.com/c-lipka/povray/releases/tag/v3.7.1-alpha.8443996%2Bav80


Post a reply to this message

From: clipka
Subject: Re: problem with installing latest 'development build'
Date: 5 Feb 2016 19:20:10
Message: <56b4f5ea$1@news.povray.org>
Kenneth, could you do me a favour and try this brand-new build on your
XP machine? Thanks.

https://github.com/POV-Ray/povray/releases/tag/v3.7.1-alpha.8463913%2Bav107


Post a reply to this message

From: Kenneth
Subject: Re: problem with installing latest 'development build'
Date: 5 Feb 2016 21:30:00
Message: <web.56b513aec6b49ec833c457550@news.povray.org>
clipka <ano### [at] anonymousorg> wrote:
>
> Kenneth, could you do me a favour and try this brand-new build on your
> XP machine? Thanks.
>
> https://github.com/POV-Ray/povray/releases/tag/v3.7.1-alpha.8463913%2Bav107

YES, this new one works. Wonderful; thanks for such a quick response. :-)

Regarding the last 'experimental development build' that also worked for me: I
honestly can't be sure of the exact version, although I *think* it was the one
immediately prior to your new 'official' development-build branch. (If that
makes any sense...) Sorry to say that I no longer have it on my computer; but if
I can find a reference to it somewhere, possibly in one of my older posts, I'll
report back.


Post a reply to this message

From: Kenneth
Subject: Re: problem with installing latest 'development build'
Date: 5 Feb 2016 21:45:00
Message: <web.56b51790c6b49ec833c457550@news.povray.org>
"Kenneth" <kdw### [at] gmailcom> wrote:

>
> Regarding the last 'experimental development build' that also worked for me...


I found a reference to it...

https://github.com/c-lipka/povray/releases/tag/v3.7.1-alpha.8431463%2Bav74

If you recall, it's the version in which you fixed the 'transmit all' /
alpha-channel PNG image quirkiness that I posted about.


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.