POV-Ray : Newsgroups : povray.beta-test : POV-Ray v3.7.1-beta.4 Released Server Time: 26 Apr 2017 23:23:10 GMT
  POV-Ray v3.7.1-beta.4 Released (Message 1 to 10 of 17)  
Goto Latest 10 Messages Next 7 Messages >>>
From: clipka
Subject: POV-Ray v3.7.1-beta.4 Released
Date: 4 Mar 2017 15:31:52
Message: <58badde8$1@news.povray.org>
Beta 4 is out, and Windows XP compatibility is back with a vengeance:
full 64-bit XP support has been restored, the 32-bit SSE2 binary should
be fixed to run on XP again, and both 32-bit binaries now also enjoy a
performance gain from switching to VS2015, just like the previous beta's
64-bit binary:

https://github.com/POV-Ray/povray/releases/tag/v3.7.1-beta.4

64-bit non-XP users might also benefit, thanks to some bugfixes.

Happy testing!


Post a reply to this message

From: StephenS
Subject: Re: POV-Ray v3.7.1-beta.4 Released
Date: 4 Mar 2017 15:52:36
Message: <58bae2c4@news.povray.org>
On 04/03/2017 10:31 AM, clipka wrote:
> Beta 4 is out, and Windows XP compatibility is back with a vengeance:
> full 64-bit XP support has been restored, the 32-bit SSE2 binary should
> be fixed to run on XP again, and both 32-bit binaries now also enjoy a
> performance gain from switching to VS2015, just like the previous beta's
> 64-bit binary:
>
> https://github.com/POV-Ray/povray/releases/tag/v3.7.1-beta.4
>
> 64-bit non-XP users might also benefit, thanks to some bugfixes.
>
> Happy testing!
>
pvengine-sse2.exe working ;-)
Copied over cmedit32.dll from v3.7\bin

Will continue more testing.

Stephen S


Post a reply to this message

From: StephenS
Subject: Re: POV-Ray v3.7.1-beta.4 Released
Date: 4 Mar 2017 15:56:23
Message: <58bae3a7$1@news.povray.org>
...
> pvengine-sse2.exe working ;-)
> Copied over cmedit32.dll from v3.7\bin
>
> Will continue more testing.
>
> Stephen S
That should be cmedit32-sse2.dll

Stephen S


Post a reply to this message

From: LucasGrijander
Subject: Re: POV-Ray v3.7.1-beta.4 Released
Date: 4 Mar 2017 21:15:00
Message: <web.58bb2d88aa7b7a9f459185810@news.povray.org>
clipka <ano### [at] anonymousorg> wrote:
> Beta 4 is out, and Windows XP compatibility is back with a vengeance:
> full 64-bit XP support has been restored, the 32-bit SSE2 binary should
> be fixed to run on XP again, and both 32-bit binaries now also enjoy a
> performance gain from switching to VS2015, just like the previous beta's
> 64-bit binary:
>
> https://github.com/POV-Ray/povray/releases/tag/v3.7.1-beta.4
>
> 64-bit non-XP users might also benefit, thanks to some bugfixes.
>
> Happy testing!

Thank you, this beta works on Windows XP64 flawlessly!!! :)


Post a reply to this message

From: dick balaska
Subject: Re: POV-Ray v3.7.1-beta.4 Released
Date: 6 Mar 2017 17:42:51
Message: <58bd9f9b$1@news.povray.org>
Am 2017-03-04 10:31, also sprach clipka:
> Beta 4 is out,

You snuck in updating from vs2010 to vs2015. Nice!
The .sln won't load because my vs2015 is too old. Boo!
...and firefox and chrome won't play on the m$ site just because...
I know I have IE here somewhere...

:)

-- 
dik


Post a reply to this message

From: clipka
Subject: Re: POV-Ray v3.7.1-beta.4 Released
Date: 6 Mar 2017 18:39:42
Message: <58bdacee$1@news.povray.org>
Am 06.03.2017 um 18:42 schrieb dick balaska:
> Am 2017-03-04 10:31, also sprach clipka:
>> Beta 4 is out,
> 
> You snuck in updating from vs2010 to vs2015. Nice!
> The .sln won't load because my vs2015 is too old. Boo!

Well, then you may want to update, don't you ;)

Sounds like you are using VS2015 "Update 0"; otherwise, let us know
details about the version you're using, and maybe also the messages
you're getting, so we can try and fix this.

We need to require Update 1 in order to ensure full XP support, as the
runtime library shipping with "Update 0" was buggy in that respect.

We could change the .sln to load in Update 0, but that would only delay
problems until you try to actually build it.

> ....and firefox and chrome won't play on the m$ site just because...
> I know I have IE here somewhere...

Did you try "Tools | Extensions and Updates..."?

(Also, I haven't seen any problems on the MS site with FireFox in a while.)


Post a reply to this message

From: dick balaska
Subject: Re: POV-Ray v3.7.1-beta.4 Released
Date: 6 Mar 2017 18:49:38
Message: <58bdaf42$1@news.povray.org>
Am 2017-03-06 13:39, also sprach clipka:
> Am 06.03.2017 um 18:42 schrieb dick balaska:
>> Am 2017-03-04 10:31, also sprach clipka:
>>> Beta 4 is out,
>>
>> You snuck in updating from vs2010 to vs2015. Nice!
>> The .sln won't load because my vs2015 is too old. Boo!
>
> Well, then you may want to update, don't you ;)

Yes. I have no problem with that as a prereq.

>
> Sounds like you are using VS2015 "Update 0";

Uhhh... sure, we'll go with that.  I can't verify because my system is 
fragilly in between downloading the 87GB update and installing it.

otherwise, let us know
> details about the version you're using, and maybe also the messages
> you're getting, so we can try and fix this.

It said "Your VS2015 is too old to load this .sln"

>
> We need to require Update 1 in order to ensure full XP support, as the
> runtime library shipping with "Update 0" was buggy in that respect.
>
> We could change the .sln to load in Update 0, but that would only delay
> problems until you try to actually build it.
>
>> ....and firefox and chrome won't play on the m$ site just because...
>> I know I have IE here somewhere...
>
> Did you try "Tools | Extensions and Updates..."?

Yeah, I didn't see anything useful.  Google suggested that and "Help | 
Check for Updates" neither of which existed. (The Help one is where I 
went first)
>
> (Also, I haven't seen any problems on the MS site with FireFox in a while.)

I hadn't either.  I finally got started with Chrome, not logged in to 
MSDN.  I even reset my firewall. It was weird.

>


-- 
dik


Post a reply to this message

From: dick balaska
Subject: Re: POV-Ray v3.7.1-beta.4 Released
Date: 7 Mar 2017 23:15:44
Message: <58bf3f20$1@news.povray.org>
Am 2017-03-06 13:49, also sprach dick balaska:
> Am 2017-03-06 13:39, also sprach clipka:
>>> You snuck in updating from vs2010 to vs2015. Nice!
>>> The .sln won't load because my vs2015 is too old. Boo!
>>
>> Well, then you may want to update, don't you ;)
>
> Yes. I have no problem with that as a prereq.
>
>>
>> Sounds like you are using VS2015 "Update 0";
>

Ah bollocks.  The only thing worse than updating a perfectly fine 
running computer, is updating it with an 87GB "patch".

8>  vidcapimpl.cpp
3>C:\Program Files (x86)\Microsoft Visual Studio 
14.0\VC\include\crtdefs.h(10): fatal error C1083: Cannot open include 
file: 'corecrt.h': No such file or directory
1>c:\users\dick\git\povray\libraries\png\pngpriv.h(45): fatal error 
C1083: Cannot open include file: 'stdlib.h': No such file or directory
5>c:\users\dick\git\povray\libraries\jpeg\jinclude.h(35): fatal error 
C1083: Cannot open include file: 'stddef.h': No such file or directory
7>C:\Program Files (x86)\Microsoft Visual Studio 
14.0\VC\include\crtdefs.h(10): fatal error C1083: Cannot open include 
file: 'corecrt.h': No such file or directory
4>C:\Program Files (x86)\Microsoft Visual Studio 
14.0\VC\include\crtdefs.h(10): fatal error C1083: Cannot open include 
file: 'corecrt.h': No such file or directory
2>c:\users\dick\git\povray\libraries\tiff\libtiff\tiffiop.h(36): fatal 
error C1083: Cannot open include file: 'fcntl.h': No such file or directory
6>c:\users\dick\git\povray\libraries\zlib\zconf.h(424): fatal error 
C1083: Cannot open include file: 'sys/types.h': No such file or directory

I'm surprised it knows crtdefs.h considering it seems to have lost 
everything else.

-- 
dik


Post a reply to this message

From: Chris Cason
Subject: Re: POV-Ray v3.7.1-beta.4 Released
Date: 8 Mar 2017 07:46:03
Message: <58bfb6bb$1@news.povray.org>
On 8/03/2017 10:15, dick balaska wrote:
> Am 2017-03-06 13:49, also sprach dick balaska:
>> Am 2017-03-06 13:39, also sprach clipka:
>>>> You snuck in updating from vs2010 to vs2015. Nice!
>>>> The .sln won't load because my vs2015 is too old. Boo!
>>>
>>> Well, then you may want to update, don't you ;)
>>
>> Yes. I have no problem with that as a prereq.
>>
>>>
>>> Sounds like you are using VS2015 "Update 0";
>>
> 
> Ah bollocks.  The only thing worse than updating a perfectly fine 
> running computer, is updating it with an 87GB "patch".

In case it's of any interest, VS2017 has just been released. Would be
interested in observations regarding speed improvements (if any) if
someone was daring enough to try it (hint hint).

https://www.visualstudio.com/downloads/

Instructions to avoid that damnable auto-download and generate an
offline installer:

https://docs.microsoft.com/en-us/visualstudio/install/create-an-offline-installation-of-visual-studio

-- Chris


Post a reply to this message

From: clipka
Subject: Re: POV-Ray v3.7.1-beta.4 Released
Date: 8 Mar 2017 13:28:26
Message: <58c006fa$1@news.povray.org>
Am 08.03.2017 um 00:15 schrieb dick balaska:

> Ah bollocks.  The only thing worse than updating a perfectly fine
> running computer, is updating it with an 87GB "patch".
> 
> 8>  vidcapimpl.cpp
> 3>C:\Program Files (x86)\Microsoft Visual Studio
> 14.0\VC\include\crtdefs.h(10): fatal error C1083: Cannot open include
> file: 'corecrt.h': No such file or directory
> 1>c:\users\dick\git\povray\libraries\png\pngpriv.h(45): fatal error
> C1083: Cannot open include file: 'stdlib.h': No such file or directory
> 5>c:\users\dick\git\povray\libraries\jpeg\jinclude.h(35): fatal error
> C1083: Cannot open include file: 'stddef.h': No such file or directory
> 7>C:\Program Files (x86)\Microsoft Visual Studio
> 14.0\VC\include\crtdefs.h(10): fatal error C1083: Cannot open include
> file: 'corecrt.h': No such file or directory
> 4>C:\Program Files (x86)\Microsoft Visual Studio
> 14.0\VC\include\crtdefs.h(10): fatal error C1083: Cannot open include
> file: 'corecrt.h': No such file or directory
> 2>c:\users\dick\git\povray\libraries\tiff\libtiff\tiffiop.h(36): fatal
> error C1083: Cannot open include file: 'fcntl.h': No such file or directory
> 6>c:\users\dick\git\povray\libraries\zlib\zconf.h(424): fatal error
> C1083: Cannot open include file: 'sys/types.h': No such file or directory
> 
> I'm surprised it knows crtdefs.h considering it seems to have lost
> everything else.

Do you have the "Windows XP Support for C++" component of VS 2015
installed? I'm sure our project files need it, and although I never
tested what /exactly/ happens when it's missing, the symptoms appear to
be at least in the right ballpark to potentially fit that bill.

Alternatively something might have gone wrong with the installation of
the updated Windows C++ runtime library. Check to see whether you have
the following directory on your machine:

    %ProgramFiles(x86)%\Windows Kits\10\Include\10.0.10586.0


Post a reply to this message

Goto Latest 10 Messages Next 7 Messages >>>

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.