POV-Ray : Newsgroups : povray.beta-test : Testing on XP required. Server Time: 18 Aug 2017 04:55:26 GMT
  Testing on XP required. (Message 1 to 10 of 14)  
Goto Latest 10 Messages Next 4 Messages >>>
From: clipka
Subject: Testing on XP required.
Date: 30 Aug 2016 04:52:52
Message: <57c51124$1@news.povray.org>
The binaries of the following build want to be tested on Windows XP
(both 32 and 64 bit):

https://github.com/POV-Ray/povray/releases/tag/v3.7.1-alpha.8764097

Only basic testing needed, to make sure they run at all.


Post a reply to this message

From: StephenS
Subject: Re: Testing on XP required.
Date: 30 Aug 2016 10:29:21
Message: <57c56001$1@news.povray.org>
On 30/08/2016 12:52 AM, clipka wrote:
> The binaries of the following build want to be tested on Windows XP
> (both 32 and 64 bit):
>
> https://github.com/POV-Ray/povray/releases/tag/v3.7.1-alpha.8764097
>
> Only basic testing needed, to make sure they run at all.
>
WinXP32, pvengine32.exe

Warning: did not find colors.inc...
Did not load GUI extension.
Basic scene ran without problem.

Stephen S


Post a reply to this message

From: clipka
Subject: Re: Testing on XP required.
Date: 30 Aug 2016 10:59:01
Message: <57c566f5$1@news.povray.org>
Am 30.08.2016 um 12:28 schrieb StephenS:
> On 30/08/2016 12:52 AM, clipka wrote:
>> The binaries of the following build want to be tested on Windows XP
>> (both 32 and 64 bit):
>>
>> https://github.com/POV-Ray/povray/releases/tag/v3.7.1-alpha.8764097
>>
>> Only basic testing needed, to make sure they run at all.
>>
> WinXP32, pvengine32.exe
> 
> Warning: did not find colors.inc...
> Did not load GUI extension.

Is that a symptom you also see with previous development builds?


Post a reply to this message

From: StephenS
Subject: Re: Testing on XP required.
Date: 31 Aug 2016 00:44:41
Message: <57c62879$1@news.povray.org>
On 30/08/2016 6:59 AM, clipka wrote:
> Am 30.08.2016 um 12:28 schrieb StephenS:
>> On 30/08/2016 12:52 AM, clipka wrote:
>>> The binaries of the following build want to be tested on Windows XP
>>> (both 32 and 64 bit):
>>>
>>> https://github.com/POV-Ray/povray/releases/tag/v3.7.1-alpha.8764097
>>>
>>> Only basic testing needed, to make sure they run at all.
>>>
>> WinXP32, pvengine32.exe
>>
>> Warning: did not find colors.inc...
>> Did not load GUI extension.
>
> Is that a symptom you also see with previous development builds?
>
It looks like every time I start pvengine32.exe 
(3.7.1-alpha.8764097+av168.msvc14.win32)

It creates a new "pvengine.ini", resetting changes.

Does this help?

pvengine.exe, 3.7.0.msvc10.win32, does not do this.

Stephen S


Post a reply to this message

From: StephenS
Subject: Re: Testing on XP required.
Date: 31 Aug 2016 01:19:55
Message: <57c630bb$1@news.povray.org>
On 30/08/2016 8:43 PM, StephenS wrote:
...
>> Is that a symptom you also see with previous development builds?
>>
> It looks like every time I start pvengine32.exe
> (3.7.1-alpha.8764097+av168.msvc14.win32)
>
> It creates a new "pvengine.ini", resetting changes.
>
> Does this help?
>
> pvengine.exe, 3.7.0.msvc10.win32, does not do this.
>
> Stephen S
pvengine.exe, 3.7.0.msvc10.win32, updates the date modified of 
"pvengine.ini" each time it's run, but keeps my changes.

example:
ExtDLL16=C:\Program Files\Bishop3D\Bishop3DPovComm.dll

Stephen S


Post a reply to this message

From: clipka
Subject: Re: Testing on XP required.
Date: 31 Aug 2016 04:36:21
Message: <57c65ec5@news.povray.org>
Am 31.08.2016 um 03:19 schrieb StephenS:
> On 30/08/2016 8:43 PM, StephenS wrote:
> ....
>>> Is that a symptom you also see with previous development builds?
>>>
>> It looks like every time I start pvengine32.exe
>> (3.7.1-alpha.8764097+av168.msvc14.win32)
>>
>> It creates a new "pvengine.ini", resetting changes.
>>
>> Does this help?
>>
>> pvengine.exe, 3.7.0.msvc10.win32, does not do this.
>>
>> Stephen S
> pvengine.exe, 3.7.0.msvc10.win32, updates the date modified of
> "pvengine.ini" each time it's run, but keeps my changes.

To re-iterate my quiz question:

Is that a symptom you also see with previous DEVELOPMENT builds?
E.g. this one:

https://github.com/POV-Ray/povray/releases/tag/v3.7.1-alpha.8737777

I need to know if this effect is something I've introduced with the new
build procedure, or whether it's a pre-existing bug introduced earlier
during development.

If you see the symptom with 3.7.1-alpha.8737777 as well, I might ask you
to also try this one:

https://github.com/POV-Ray/povray/releases/tag/v3.7.1-alpha.8451792%2Bav100

And if the 3.7.1-alpha.8451792 doesn't have it, I'd like to ask you to
try releases in between (excluding those marked "experimental"), to
narrow down where the error was introduced.

If you have the time of course.


Post a reply to this message

From: StephenS
Subject: Re: Testing on XP required.
Date: 31 Aug 2016 10:08:51
Message: <57c6acb3$1@news.povray.org>
On 31/08/2016 12:36 AM, clipka wrote:
...
> If you have the time of course.
>
Some during the week, lots during the weekend.

Will start as time permits.

Stephen S


Post a reply to this message

From: StephenS
Subject: Re: Testing on XP required.
Date: 4 Sep 2016 14:45:31
Message: <57cc338b$1@news.povray.org>
...
> If you have the time of course.
>

I have many of the builds, maybe some experimental, ops.

8451792 av100 not valid
8558038 av124 working
8586521 av129 not valid


8737777 av158 not valid
8764097 av168 working, missing color.inc

working through more.

Stephen S


Post a reply to this message

From: clipka
Subject: Re: Testing on XP required.
Date: 4 Sep 2016 15:31:47
Message: <57cc3e63$1@news.povray.org>
Am 04.09.2016 um 16:44 schrieb StephenS:
> ....
>> If you have the time of course.
>>
> 
> I have many of the builds, maybe some experimental, ops.
> 
> 8451792 av100 not valid
> 8558038 av124 working
> 8586521 av129 not valid

That's seriously odd, as the build process hadn't changed between the
latter two.

I presume that "not valid" means Windows XP is claiming the .exe to be
not a valid XP application, and that you're making sure to run the
32-bit version, right?


Post a reply to this message

From: StephenS
Subject: Re: Testing on XP required.
Date: 4 Sep 2016 15:34:42
Message: <57cc3f12$1@news.povray.org>
On 04/09/2016 10:44 AM, StephenS wrote:
> ...
>> If you have the time of course.
>>
>
> I have many of the builds, maybe some experimental, ops.
>
> 8451792 av100 not valid
8514084 av121 working
8545805 av122 working
8555867 av123 working
> 8558038 av124 working
> 8586521 av129 not valid
8600570 av138 not valid
...all not valid
8730959 av156 not valid
> 8737777 av158 not valid
> 8764097 av168 working, missing color.inc
>
> working through more.
>
> Stephen S
The testing is for pvengine32.exe only, not "-sse2"
Both can run on my computer.
Athlon64 X2 Dual, 4200+, 2gb ram
WinXP sp3 (Media center edition)


Post a reply to this message

Goto Latest 10 Messages Next 4 Messages >>>

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.