POV-Ray : Newsgroups : povray.beta-test : Subsurface scattering : Re: Subsurface scattering Server Time: 30 Mar 2020 14:09:54 GMT
  Re: Subsurface scattering  
From: Mike Horvath
Date: 5 Feb 2018 09:50:07
On 2/5/2018 4:20 AM, Mike Horvath wrote:
> I tried an old scene that worked properly in uberpov, but I see no 
> effect in 3.7.0 or 3.8.0 alpha.
> 
> Here are my global_settings:
> 
> 
> global_settings
> {
>      assumed_gamma    1
>      #if (Use_Radiosity = 1)
>          radiosity
>          {
>              pretrace_start    0.1
>              pretrace_end    0.001
>              recursion_limit    2
>              count            3
>              nearest_count    20,10
>              always_sample    off
>              maximum_reuse    0.1
>              minimum_reuse    0.001
> //            no_cache
>          }
>      #end
>      ambient_light    0
> //    mm_per_unit        0.4
>      mm_per_unit        1/4000
>      adc_bailout        0.001
>      max_trace_level    8
>      subsurface
>      {
>          samples 5, 5
>          radiosity true
>      }
> }
> 
> 
> Here is my finish:
> 
>      #declare lg_solid_finish = finish
>      {
>          ambient    0
>          #if (lg_quality >= 2)
>              diffuse albedo    0.9
>              specular albedo    PlasticSpecularity
>              roughness PlasticRoughness
>              fresnel on
>              reflection
>              {
>                  PlasticSpecularity
> //                roughness PlasticRoughness
>                  fresnel on
>              }
>          #end
>          conserve_energy
>      }
> 
> 
> Are there additional settings I am missing?
> 
> 
> Mike


	#declare PlasticSpecularity  = 1.0;
	#declare PlasticRoughness    = 0.001;


Mike


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.