POV-Ray : Newsgroups : povray.animations : animation Server Time: 18 Jun 2019 04:37:29 GMT
  animation (Message 1 to 3 of 3)  
From: ng39
Subject: animation
Date: 20 Oct 2012 20:35:00
Message: <web.508309c98d5284dc6fc484a50@news.povray.org>
Hai all,
         I was trying to do a animation using pov-ray but unable to get a smooth
animation.. The change in frames is clearly seen.. I tried to change the anti
alias depth which showed a little effect but still we can see the change of
frames.. Help me out with this guys..
Thanks in advance.


Post a reply to this message

From: Christian Froeschlin
Subject: Re: animation
Date: 20 Oct 2012 21:15:57
Message: <5083148d@news.povray.org>
> still we can see the change of frames

Did you disable jitter?

If you use radiosity that might also contribute something.


Post a reply to this message

From: Alain
Subject: Re: animation
Date: 21 Oct 2012 20:14:58
Message: <508457c2@news.povray.org>
Le 20/10/12 4:30 PM, ng39 a écrit :
> Hai all,
>           I was trying to do a animation using pov-ray but unable to get a smooth
> animation. The change in frames is clearly seen. I tried to change the anti
> alias depth which showed a little effect but still we can see the change of
> frames.. Help me out with this guys.
> Thanks in advance.
>
>
>

If the animation itself is not smooth, it can mean that you don't 
generate enough frames. A 2 FPS animation can't be smooth...

Antialiasing is used to smooth out the jaginess of oblique or curved 
edges, not smooth out the frames of an animation.

As Christian mentioned, it's usualy beter to disable jitter when doing 
an animation, but it can be used to simulate the image noise of some 
older movies.

If you use radiosity, you need to increase some quality parameters.
(the radiosity tips are seriously outdated)
Reduce pretrace_end to 0.01, 0.005 or 0.0025 from the default of 0.04.
Increase the count value.
If using version 3.7, and using a large count value (over 1000), it's 
beter to use adaptive sampling with importance.
To use that feature, you need to:
Add early in the source:
#declare Target_Average_Count = 60;
#declare Max_Rad_Count = 2000;
#default{radiosity{importance Target_Average_Count/Max_Rad_Count}}
global_settings{radiosity{... count Max_Rad_Count ...}}

In relatively small but important objects, add:
radiosity{importance 1}

Reduce low_error_factor from de default of 0.5. It can be as low as 0.1 
or even less.
Increasing nearest_count to 20 may also help. In version 3.7, you can 
use 20, 5 for that parameter.
Try reducing adc_bailout, especialy if you use emissive objects as light 
sources.
If you use version 3.7 RC6, use +HR on the command line or 
High_Reproducibility in an ini file.


Alain


Post a reply to this message

Copyright 2003-2008 Persistence of Vision Raytracer Pty. Ltd.